Download

Unreal Engine 4 is available for Win10 UWP app dev now

@MrNexy @Sentinel

I think you’re both hitting the same problem - we needed some quotes around the appx path to signtool. Try again with commit 9470688.
@Keresh

Yes, a build for Lumia 950 would require ARM which is not currently available. We don’t have anything to announce concerning future plans for this fork, but please do keep providing feedback on what you might be interested in. And if you decide to add ARM support yourself do let us know how it goes.

@jsyarrow , [MENTION=3956]James Barnette[/MENTION]

That sorted out the signing side of things. Everything now cooks,builds,packages and deploys without a hitch for UWP32 and UWP64 for the pc.
Now that the packages are signed I am able to successfully install them on my XBO through the device portal.

04cf42c0164acc33032f49573fae82382098f1f9.jpeg

76859f4d6d2f7c4669e4511d5e81829a57810853.jpeg

When I start up the application through the device portal the splash screen loads up on my TV and hangs there for a while. I’m then kicked back to the dashboard on the XBO and receive the following message in the device portal.

FailedToStartPackage.jpg

I don’t get any debug information(that I know where to find at any rate). After reading through the known issues for UWP on XBO and the resources allocated to UWP on XBO, I’ve come to the conclusion that the app is likely exceeding the available resources and throwing a memory allocation failure and closing. I get the feeling that this is as far as I’m going to get in terms of testing on the XBO, I could be wrong of course and would be very happy to be proven so. What I imagine is that the engine would have to be optimized to run on such limited resources, likely in much the same way as it has been to run on android. That said I am probably going to try and package a scalable prototype that I’ve been working on (and have packaged and run on android) for further testing.

What you are getting is a memory message because Xbox only lets you use half the ram In dev mode you need a dev kit to use the full features it has

Yup , from the specs it looks like UWP apps are limited to 1GB of memory on XBO. This is likely why basic unity apps run like tar. Let alone trying to run UE4. Looks like I’m going to be fleshing out one of my prototypes and re-applying to ID@XBOX :slight_smile:

Ya same I am going to apply again when I have a working muiltyplayer prototype

Wow exciting progress, guys!

I just got back from vacation. Excited to hop back in the UWP UE4 development boat. :smiley:

Update: S U C C E S S !
I’ve successfully built an app in UE4, packaged for UWPx86, and deployed it to a Microsoft HoloLens! YAY! However, I’m noticing some issues already.

When packaging for UWP, the Quit Game node does not function correctly. It does not exit/quit the game. I also tried an Execute Command node with the command “EXIT” executed. Also nothing. Both of these methods for exiting the application work just fine in the editor, but not in the resulting appx from the UWP packaging. I am packaging for UWP x86 - 32 bit. What is going on here?

My next challenge to tackle is to make the app into a 3D holographic app instead of a 2D app. If anybody has any great ideas on how I might do that, please let me know.

Hi. Does this fork have Holograpic APIs integrated?

To start getting it rendering as a 3D holographic app you’ll have to see what’s required from here: https://developer.microsoft.com/en-us/windows/holographic/directx_development_overview. Would love to look at this myself but don’t think I’m going to have time in the near term at least to take it on.

After that though it would be great to have the C++ Hololens libraries accessible from blueprints. (Gaze, gestures, spatial mapping, etc)

Today’s push addresses a couple of problems that were blocking this from running in Xbox One dev mode. Specifically we needed to adjust the linker input when using the 14393 Windows 10 SDK to get an image that could run on Xbox One, and we needed to allow D3D Feature Level 10 in UWP builds, since that’s what the Xbox One dev mode driver provides. I’d be interested to hear the results if you give it another shot.

It’s super exciting to hear you’ve got this running on HoloLens for 2D apps. And thanks for the report on quit behavior. We’ve pushed a change that should improve this a bit - in particular UWP builds should actually respond to the exit command now.

Not yet… :cool:

It would be great, wouldn’t it? :cool:

I’m hoping I can help make these things a reality. My work lately has been (almost) exclusively with the HoloLens, so this will be my primary focus for the near future. I will be posting my progress.

Also, thanks so much for your commits @jsyarrow , you’re the man!

That sure is a welcome bit of news. I’ll give it another go sometime tomorrow and post the results, thank you ! :slight_smile:

I am new to the thread, and I am pretty much in the same spot some of you are with porting from UE4 to XboxOne through UWP Deployment, where basically, the game crashes at the splash screen after running the in developer mode on the XboxOne. The game I am running utilizes far less than 1GB of memory, and is quite small so I am pretty sure it is not a matter of the application exceeding available resources…
I haven’t tested the UWP build uploaded today 8/11, but willing to give it another shot with that hopefully within the next day, I can certainly report my results once done as well.

I look forward to see them :slight_smile:

I am happy to report that the 8/11 build works perfectly for porting from PC to XboxOne! No more crashing at the splash screen. If anybody needs help with porting let me know.

Just one quick update… A 2D UE4 game works… But When trying to port a 3D Game (the First Person Template), XboxOne will still crash at the start screen with more than enough resources available to run it on the XboxOne. I am guessing this is still do to a D3D issue. Either way, I am really happy that at least 2D Game builds work!

Update: Still no 3D Holographic app yet. Just getting back in the swing of things from the weekend. Been diving into the HoloToolkit and some Unity examples. I’m pretty sure I can include the gesture/voice/gaze/spatial perception stuff. I just need to find the ‘switch(es)’ to make Unreal build a 3D holographic app. Going to look into the UE4 VR stuff to see if I can get a hint.

Is there anybody trying to get Unreal on the HoloLens out there? Or is it just me? I feel like I’m so close, yet so far. Hopefully I’ll have a more insightful update soon.

Cheers!

I’m highly interested in getting it to work however I may not be able to get to this in the near time and help out. I’ll update the thread if I do make any progress though. We’ve been using Unity since the integration is already done but really would love to get Unreal working.

Original post (8-19-2016):
We are in the same boat. We’ve been using Unity but there is a lot of desire to work with Unreal for our Holographic apps, etc.

I’ve been diving into the DirectX documentation, and UE4 uses DX11 to render as a default on windows, so I know it’s doable. If only the Holograms App source code was public. I’m pretty sure that would help a lot. Then again, I’m not sure if the Holograms App was made with Unity, or with another route.

I’ve learned enough about DirectX to render to swap chains as well as holographic spaces, now I just need to get Unreal to render to a holographic space. I’d like to get some insight from someone who knows a lot about how UE4 rendering gets done. I have been using UE4 for a while now, but I’ve never had to actually change the render pipeline; i’m struggling a little bit on that front.

UPDATE 8-31-2016:
Making some cool progress! Got all the hololens device resources and stuff in my UE4 UWP build, now we need to render the project stuff in the holographic space properly, etc. It’s been tough fitting time for this in-between other projects, but Unreal on the HoloLens is slowly becoming a reality!

Drop down File menu not work in Windows 10.14915.1000. The same is with toolbar drop down options
No drop down menu work ever, even when right click mouse button was clicked
And I have permanent error during UWP64 packaging:
“MakePri: error 0x80080204: Appx manifest not found or is invalid. Please ensure well-formed manifest file is present. Or specify an index name with /in switch.”
Guys is this project even work for at least 10 people?!?!?!
[This project is absolutely joke]

BUILD FAILED
I have these errors during “Packaging project for UWP (x64-64bit)” in UE4Editor 4.12.5:
“Empty or invalid value provided for required attribute Square150x150Logo …”
“Empty or invalid value provided for required attribute Square44x44Logo …”
“Empty or invalid value provided for required attribute Image on partially …”
“Validation error reading XML schema from XDK. The element ‘Properties’ in namespace …”
“Validation error reading XML schema from XDK. The element ‘Application’ …”
“MakePri: error 0x80080204: Appx manifest not found or is invalid. Please ensure well-formed manifest file is present. Or specify an index name with /in switch. …”

Update:
After days I resolve these errors: I put some cpp code in my only BluePrint project, because I think, BP-only projects are not supported in current port version 4.12.5