Download

Unreal Engine 4 is available for Win10 UWP app dev now

Epic probably just not interested enough in the platform to spend own resources on it (Epic has very limited resources to be honest).
And MS seems not very interested in it eather since it’s not officially maintained by it (“This project is community-supported”).

Is anyone working on WMR support in 4.18, by chance? It looks like the release_uwp branch recently hit 4.18, but the WMR branch is still on 4.16.2.

I’m not sure the team working on the Windows MR support follow these forums. You might try asking your question directly on the git repo as an issue.

Meanwhile, as mentioned, the non-MR branch is now caught up with 4.18. In the process I think we’ve dealt with most of the recent build problems that people were running into up-thread. Also a couple of things that came in over the summer that are old news now, but which I don’t think I previously mentioned here:

  • You can now launch on remote UWP devices (another PC, or an Xbox One in dev mode) directly from the project launcher. You do need to make sure that Windows Device Portal is enabled for your remote device (it’s in the developer page of Windows settings, or in Dev Home on Xbox) and then claim your device from the Unreal Device Manager,
  • We now by default include a plugin to integrate with Mixer interactivity. Visit GitHub - mixer/interactive-unreal-plugin for more details on this. Note: I think this is currently having some issues when building with VS2017, so if you turn it on you may need to use VS2015 or else hack some headers.

P.S. For a look at another UE project I’ve been helping out with recently check out https://www.microsoft.com/en-us/store/p/insects-an-xbox-one-x-enhanced-experience/9p798w4vdt91?rtc=1. Especially recommended if you have a fancy new Xbox One X.

it would go a hell of a lot easier if there was someone who can just post binary builds of the latest versions. im getting this bloody error

upon building the project files:

Setting up Unreal Engine 4 project files…
C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin
Microsoft.Common.CurrentVersion.targets(1988,5): warning MSB3245: Could not res
olve this reference. Could not locate the assembly “Windows”. Check to make sur
e the assembly exists on disk. If this reference is required by your code, you
may get compilation errors. [C:\unreal uwp\Engine\Source\Programs\UnrealBuildTo
ol\UnrealBuildTool.csproj]
Platform\UWP\WinMDRegistrationInfo.cs(4,26): error CS0234: The type or namespac
e name ‘Metadata’ does not exist in the namespace ‘Windows.Foundation’ (are you
missing an assembly reference?) [C:\unreal uwp\Engine\Source\Programs\UnrealBu
ildTool\UnrealBuildTool.csproj]

GenerateProjectFiles ERROR: UnrealBuildTool failed to compile.

Hello James.
Possibly a dumb question. . .but are you releasing the project files for Insects given that it is a technical demo?

is it not possible for someone to upload a completed windows binary build of the latest version somewhere ? cuz i apparently suck at trying to get it to compile :frowning: sighs.

ok turns out the xbox one’s dev mode is just not gonna cut it for higher end games it may do fine with simple graphics setups but in unity when a scene has a lot of stuff in it it just slows down. i think im just gonna focus on pc devolpment for now… but hey i tried.
for those on the fence personally id stick with PC devolopment rather then doing so on the xbox one with dev mode i think to really get the full use of the xbox one youd need to register as a company at ID@xbox id imagine. dev mode is nice for hobbiests and simple games but too limiting for bigger ideas.

@Evenios - the original error you posted looks rather like UE can’t locate the Windows 10 SDK. The build system is not finding Windows.winmd, which typically is in [Program files(x86)]\Windows Kits\10\UnionMetadata (or somewhere like that). But I wonder whether the 16299 SDK has moved it exclusively to a versioned folder? Which could be a problem if that’s the only SDK you have installed.

On Xbox One you might want to make sure that your project is being categorized as a game on the Xbox. You can highlight your app in Dev Home, press the View button, and then select View details. If the App type says ‘App’, then you have limited access to system resources. Changing that to ‘Game’ will allow you to use more of the hardware. And if you end up submitting to the Windows Store, make sure your submission is marked as a game to get the same resources in a retail scenario.

Note that to take full advantage of the GPU on an Xbox One UWP title flagged as a ‘game’ you must use D3D12. But the current code in the fork runs into problems when using the D3D12RHI on Xbox. I hope we’ll have a fix for that in the future.

@Jerry.Richards - no plans to release the project source. It’s an Xbox One XDK project which creates some restrictions and also makes it less useful to the internet at large. XDK developers in particular may see (or have already seen) selected elements of the work appear in some of our developer outreach materials.

Okay, thank you @jsyarrow

I finally built UWP UE4 and can launch to my PC as a UWP game. However, my Xbox One does not show up in the Device Manager. I can run native DirectX 12 programs on my Xbox with Visual Studio and I have Remote Access/Windows Device Portal enabled for my Xbox. At one point I did see my Xbox listed there and I was able to claim it, but it’s not showing up any more. Any ideas?

Thanks!

I got a fix from github:

“Do you perhaps have authentication enabled in the ‘Remote Access Settings’ on your Xbox One? If so that would be the issue: remote UWP devices that require credentials are not currently supported by the UE integration.”

Hello, I try to compile Engine from source https://github.com/MICROSOFT-XBOX-ATG/MICROSOFT_UWP_UNREAL

But after loading dependency ‘Setup.bat’ and generation project files ‘GenerateProjectFiles.sh’ I got error during compilation in visual studio



1>  Performing 54 actions (4 in parallel)
1>  [1/54] Resource ModuleVersionResource.rc.inl
1>  [2/54] Resource PCLaunch.rc
1>C:\Program Files\Epic Games\MICROSOFT_UWP_UNREAL\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3): fatal error RC1015: cannot open include file 'windows.h'.


Do you have any ideas??

I’m using Visual studio 2015

I just pulled the repository and tried to perform a fresh build:



16>Module.ShaderCacheTool.cpp
16>E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Source\Programs\Mac\ShaderCacheTool\Private\ShaderCacheTool.cpp(66): error C2039: 'MergeShaderCacheFiles': is not a member of 'FShaderCache'
16>E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Source\Runtime\ShaderCore\Public\ShaderCache.h(142): note: see declaration of 'FShaderCache'
16>E:\UEUWP\MICROSOFT_UWP_UNREAL\Engine\Source\Programs\Mac\ShaderCacheTool\Private\ShaderCacheTool.cpp(66): error C3861: 'MergeShaderCacheFiles': identifier not found


Is anyone else encountering this?

Any recommendations is appreciated.

Solved by removing all Visual studios, C++ compilers, and Windows SDKs, and Installing new Visual studio 2017 with c++ windows sdk

Hi,

I’m receiving the following error when trying to compile for the first time in VS2015:


c:\svn\ue4uwp\engine\source\runtime\d3d12rhi\private\D3D12Residency.h(22): fatal error C1083: Cannot open include file: 'dxgi1_6.h': No such file or directory

I’m unable to continue due to this error, has anyone seen this before? I am unable to find any mention of this on the forums or google.

Windows 10 SDK 14393 installed.

I tried installing the latest Win10 SDK but no joy from that either so I uninstalled it.

Thanks,
Jon

You shouldn’t need to build the Mac ShaderCacheTool for Windows platforms. You can safely ignore this error for UWP work.

From the looks of things this problem might also exist in the mainline? Certainly I’m not aware of any changes in this area that are specific to the UWP fork.

We’ve picked up some changes to the DX12 RHI that rely on newer (post-14393) versions of DXGI. For desktop these are included in the ThirdParty folder, but for UWP we try to get everything from the Windows SDK and 14393 doesn’t have what’s needed. Later SDKs, however, are not supported with VS2015, which would explain why your attempt to upgrade didn’t fix the problem. I only recently became aware of the issue and I’m still thinking about what the best path forward is. In the meantime to workaround your problem you can either upgrade to VS2017 (most future-proof) or else make some engine edits to avoid compiling the D3D12RHI (assuming DX11 only meets your needs).

I’m trying to visit the repo linked in this thread (https://github.com/MICROSOFT-XBOX-ATG/MICROSOFT_UWP_UNREAL) and I’m getting a 404. It looks like people have visited in the past couple of days. Is it just me?

That was my first thought too. I’m assuming you’re not encountering the error.

Ah that explains a lot. Thanks!