Unreal Engine 4.9 Released!

I am quite sure UE4 is doing this automatically, where should I manually do it? The common way to update a project is to start the new version, open the old project and select “create copy”. Then UE4 creates the copy and automatically starts the project - do you think I should then close the project, delete the binary and intermediate folder, and reopen it? It’s always compiling all the shaders again after it’s updated to a new version, so I think this means it has deleted the binary and intermediate folders.

This is interesting. Updating my project made my terrain fluorescent. Only shows this way in the editor and not during play. It’s also crashing my video driver (Nvidia GTX870 on Win 10)

This looks like the navmesh preview, try pressing “P” to disable it :slight_smile:

OK, i feel stupid now… that was it

If you are experiencing the Redirectors bug listed earlier, please post to this thread or go here for updates:

I’m sorry to repeat it, but I really want to move 4.8 project to 4.9 mainly because of AO mask. If solution isn’t obvious, how can I check what’s happening at 98%? Any log files? The duplicated project folder doesn’t have any logs (project folder > Saved > Logs, no such folder).

Hi tonpix,

Try verifying your engine build by going to the launcher>library>4.9 context menu>verify. If this does not fix your error, please report this to the answerhub in the bug reports section (link in signature). In the answerhub report, please include your dxdiag, steps taken, and if you are able to open a clean, blank project from 4.9 or if no projects will open at all.

Is anyone else having issues with texture streaming? I often have textures streaming in and everything is popping in and out of very low-res mode.

Hi, I still get this error…

Have VS2015 RTM (community) along with Windows 10 SDK RTM installed.

EDIT: I was able to get 2015 project files by adding and modify some batch tools. Hopefully it will compile…

This bug is known and logged internally as UE-20401.

Actually I’ve solved it by accident. When I tried converting again and it hanged, after ctrl+alt+deling and opening Task Manager, I’ve noticed that engine was using HDD heavily, something was copying… after quick investigate, it turned out that Matinee recordings were the reason the engine was hanging and crashing - 65GB of uncompressed recordings in Saved/Video folder.

EDIT: Deleting videos solved it.

in 4.9 i have error when try to build my game(in 4.7 all works, in 4.8 i didn’t try…), here is last log message, any idea what UE wont from me?

MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd:
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: Execution of commandlet took: 59.19 seconds
MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 97,3705693s to run UE4Editor-Cmd.exe, ExitCode=1
MainFrameActions: Packaging (Windows (64-bit)): Project.Cook: Cook failed. Deleting cooked data.
MainFrameActions: Packaging (Windows (64-bit)): BuildCommand.Execute: ERROR: BUILD FAILED
MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception:
MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: Exception in AutomationScripts.Automation: Cook failed.
MainFrameActions: Packaging (Windows (64-bit)): Stacktrace: в Project.Cook(ProjectParams Params)
MainFrameActions: Packaging (Windows (64-bit)): в BuildCookRun.DoBuildCookRun(ProjectParams Params)
MainFrameActions: Packaging (Windows (64-bit)): в BuildCommand.Execute()
MainFrameActions: Packaging (Windows (64-bit)): в AutomationTool.Automation.Execute(List1 CommandsToExecute, CaselessDictionary1 Commands)
MainFrameActions: Packaging (Windows (64-bit)): в AutomationTool.Automation.Process(String] CommandLine)
MainFrameActions: Packaging (Windows (64-bit)): в AutomationTool.Program.MainProc(Object Param)
MainFrameActions: Packaging (Windows (64-bit)): в AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param)
MainFrameActions: Packaging (Windows (64-bit)): в AutomationTool.Program.Main()InnerException in AutomationUtils.Automation: BUILD FAILED: Failed while running Cook for D:\Games\UE4_sources\UE_projects\HALO\HALO.uproject; see log C:\Users\zip\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Games+UE4_sources+LAUNCHER+Unreal+Engine+4.9\Cook-2015.09.02-20.07.12.txt
MainFrameActions: Packaging (Windows (64-bit)): Stacktrace: в AutomationTool.CommandUtils.RunCommandlet(String ProjectName, String UE4Exe, String Commandlet, String Parameters)
MainFrameActions: Packaging (Windows (64-bit)): в Project.Cook(ProjectParams Params)
MainFrameActions: Packaging (Windows (64-bit)): ProcessManager.KillAll: Trying to kill 0 spawned processes.
MainFrameActions: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=Error_UnknownCookFailure
MainFrameActions: Packaging (Windows (64-bit)): Domain_ProcessExit
MainFrameActions: Packaging (Windows (64-bit)): copying UAT log files…
MainFrameActions: Packaging (Windows (64-bit)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.
MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults:Error: Error Unknown Cook Failure

Okay, after converting to 4.9, I’ve noticed I have lower framerate by 5-10 FPS. Same camera, I haven’t changed anything. Perhaps 4.9 has different default settings anywhere than 4.8 that lowered framerate from 50ish to 40ish?

There’s screenshot, not only framerate is lower, but number of objects and memory usage is higher. This objects number is interesting, how to check what caused additional almost 2000 objects?

EDIT: Another bug, when ‘walking’ with camera, and holding strafe keys (side movements, A/D keys) and look around with mouse, the camera is super jerky, no smooth looking around like in 4.8.

I have to say for us this has been by far the most problematic update so far. Also getting this when I hit play:

It’s part of the VR template I guess, don’t know what causes it.

Please report these bugs to the answerhub (link in signature) in the bug reports section so we can assist you more in depth.

Please report this on the answerhub in the bug reports section so we can assist you further. In it, please include what steps you took to reproduce this on your end. Additionally, include whether this project was updated from a previous version or if it was created new in 4.9, whether this occurs in a clean project, and any additional information that may help us to determine what is occurring and potentially reproduce the error.

My game on android Galaxy s3: U 4.8 -34 fps up U4.9 52 fps :::)))))))))))))
Galaxy s2 : U 4.8 32 fps down U4.9 16 fps :(((((((((((((((((((((

This update suxx :stuck_out_tongue: i have many bugs .Etc… I stay with U4.8 .

Major FPS drop here from a 4.7 project opened in 4.9. And also getting the external packages error. Crashes when trying to run standalone…