Download

Unreal Engine 4.9 Released!

I just tried posting a new question on the AnswerHub and it seemed to work fine. Would you be able to try again, please?

Tim

It has always worked on Win10.
I was just using 4.8 on win 10 a day ago!

Took a couple tries on answerhub to get it posted over there. Kept getting an error message.
https://answers.unrealengine.com/questions/295160/activeclassredirects-collision-load-error-after-49.html

Having the same issue as someone else reported in this thread for activeclassredirects load errors.

http://numbat.ninja/wp-content/uploads/2015/09/activeclassredirects.jpg

I ran fix up redirectors in both my content folder and the engine content folder and that did not solve the problem.

I have this issue too,please fix that,it’s a bit annoying…

Here is another bug…

Deleted an asset, created a new one… attempted to undo then the editor crashed at the following line of code…

EDIT: For further details, ObjectIndex is 65537 but the size of the ReferencedObjects array is 2

ANSWER HUB LINK: [4.9.0] - Undo In Certain Case Causes Crash - UE4 AnswerHub

Guys… When updating projects to new major release, remember to delete Binary folders and Intermediate folders, to have a fresh build of the project copy.
Many of the issues some report may be because you simply didn’t delete these folders before upgrading.

Just found another bug which is probably related to the parent issue but I just applied a Material to a base class and it reset all materials for any parents that are based off of that child BP… Okay… this is bad Epic. Thankfully, I’ll just keep my other game in 4.8.3 in the meantime but this is going to waste a lot of time if I have to go back and fix the parent class materials every time I need to change the base one.

EDIT: I just tested it a second time and same thing. This is extremely upsetting…

ANSWER HUB LINK: [4.9.0] - Materials Constantly Get Overriden By Base Class Material Changes - UE4 AnswerHub

I am getting frequent crashes selecting multiple parameter nodes in the material editor (Assertion failed IsValid()). Beware, don’t try to ctrl+click on parameters. For what it’s worth I was clicking on scalar and vector parameters in no particular order.

oO linux dedicated server – initial observations: memory usage for our game dropped by about 30% with this version!! Woohoo!

Useful information. Is there a documentation page that lists what should be done before upgrading a project? (aside from backing up)

I am quite sure UE4 is doing this automatically, where should I manually do it? The common way to update a project is to start the new version, open the old project and select “create copy”. Then UE4 creates the copy and automatically starts the project - do you think I should then close the project, delete the binary and intermediate folder, and reopen it? It’s always compiling all the shaders again after it’s updated to a new version, so I think this means it has deleted the binary and intermediate folders.

This is interesting. Updating my project made my terrain fluorescent. Only shows this way in the editor and not during play. It’s also crashing my video driver (Nvidia GTX870 on Win 10)

http://s11.postimg.org/4v6pz4ogv/2015_09_01_22_47_07.jpg

This looks like the navmesh preview, try pressing “P” to disable it :slight_smile:

OK, i feel stupid now… that was it

If you are experiencing the Redirectors bug listed earlier, please post to this thread or go here for updates:

https://answers.unrealengine.com/questions/294187/redirectors-bug.html

I’m sorry to repeat it, but I really want to move 4.8 project to 4.9 mainly because of AO mask. If solution isn’t obvious, how can I check what’s happening at 98%? Any log files? The duplicated project folder doesn’t have any logs (project folder > Saved > Logs, no such folder).

Hi tonpix,

Try verifying your engine build by going to the launcher>library>4.9 context menu>verify. If this does not fix your error, please report this to the answerhub in the bug reports section (link in signature). In the answerhub report, please include your dxdiag, steps taken, and if you are able to open a clean, blank project from 4.9 or if no projects will open at all.

Is anyone else having issues with texture streaming? I often have textures streaming in and everything is popping in and out of very low-res mode.

Hi, I still get this error…

Have VS2015 RTM (community) along with Windows 10 SDK RTM installed.

EDIT: I was able to get 2015 project files by adding and modify some batch tools. Hopefully it will compile…

This bug is known and logged internally as UE-20401.