Unreal Engine 4.7 Released!

Hi WCode,

It is in the same boat as Frozenfire’s bug. It has been fixed, marked as high priority and is slated to be in 4.8.

If it’s high priority and fixed it would be something for a possible 4.7.5? :rolleyes:

Why do the updates just does not replace things and not re download the whole thing. I just finished installing 4.7.3 after 2 days of download. after 3 seconds 4.7.4 came out suddenly and force me to download 4 gb again. I didn’t even have a chance to open the editor. Question: Is it really forced to update or I just messed something? I don’t see 4.7.3 anymore.

Here’s a launcher bug:

I thought it was re-downloading 4.7.3 again, instead of updating to 4.7.4 :rolleyes:

Ok that is great!

Is Oculus v0.5.0 SDK supported in UE4.7.4 ?

Possibly. Although at this moment we haven’t committed to any plans for a 4.7.5 Hotfix. It also needs to be noted that not every fix can be included in a Hotfix. Some fixes and updates can only be introduced in the major releases because otherwise they may break binary compatibility and some projects for the release version couldn’t be opened any longer.


Restart the launcher before upgrate anything !

Structure default values appear to still not be working properly unfortunately. :frowning:

UE-12206 GitHub 944 : UE-12128: Properly save structs when struct field default value is different

I think it works if you have no inheritance (one BP class with no children). But if you have inherited BPs using these struct and you set the values to new values, then the bug comes back (click compile and some values are zeroed).

I would also like to know when 0.5.0 will be added, any update?

Hi All.
I got problem with new update And new update.
I dont know download which one Version .
when finish download 4.7.3 , New Version Up Coming 4.7.4 and I Cant Use Version 4.7.3 until Download Version 4.7.4.Please Help Me?

I think every minor update to major version is mandatory to re download the whole thing again. I think patching with a less download size should be the updating method.

I’m pretty sure I had the latest version of the launcher :wink:
I opened it to launch the editor and then the update for 4.7.3 showed up. ^^
However, instead of “updating to 4.7.4”, it said “downloading 4.7.3”.
No big deal, it was downloading 4.7.4 anyway and it’s working fine, thanks Epic! :smiley:

That one is fixed internally, but the integration didn’t make it into 4.7.4 in time. It is slated for a 4.8 fix. Please let us know if it is not fixed after the 4.8 release.

Hi everyone,

We have identified a new issue with the Launcher where the yellow [Launch Unreal Engine 4.7.3] button is automatically downloading and installing the latest hotfix. This is not intentional behavior, since only clicking the [Update] button should cause the update to occur. If you are on 4.7.3 and and do not wish to update at this time, you can continue using 4.7.3 by launching directly into your project from the Library, or by using the Launcher in “Offline Mode”.

Additionally, we are currently investigating some reports of Blueprint crashes after updating to 4.7.4. If you also experience a crash in your project upon startup after updating to 4.7.4, please let us know by making a report to the Bug Reports section of the AnswerHub (follow link in my signature).

Thank you, and we apologize for the inconveniences from either of these issues.

So there is a chance for a 4.7.5 fixing the crashes and including the new better struct default value fix? :cool:

Thanks for clearing it up. But is hotfix update intended to redownload the whole engine again or should it just patch?

The Mac texture issue was really annoying, thanks!

It still not saving the values of the struct correctly… I understand if it was fixed in the master branch, but… my problem is not being able to download 4.7.2 anymore. 4.7.2 works for me, but I can’t use 4.7.3 or 4.7.4…

… sad frog is sad.