Unreal Engine 4.23 Released!

No

Probably not, I don’t have UDN access. I reported it but I’ll get an email from someone who can’t understand the issue and wont elevate.

Particle “Initial Size” also completely broken.

[USER=“7”]Jeff Wilson[/USER] a BIG release! Will take a while to properly read up on all the changes that are relevant to me.
Many thanks to all involved in making UnrealEngine even better!

Out of curiosity - do you celebrate a new launch in some way? All go out for a drink?

Does DXR still have to be activated in 4.23 from the command line by -dx12 option ?

I can’t install the new version from the EpicLauncher.

So can anyone build and launch WindowsMR plugin projects with the final 4.23? I can’t test because Datasmith prevents me from launching, but just a day or so ago I got this with preview 8:

https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1640558-unreal-engine-4-23-preview?p=1660070#post1660070

Looks like all arrays I have in a project are broken. As soon as I try to expand an array element other than ID 0 the editor crashes. I tried to empty the array and fill it up from scratch but as soon as I add something to the 2nd array element (ID 1) the editor crashes.

An array of what type?

Getting very heavy fps hit (fps goes to 10) in DX12 with my landscape material that work smooth (over 60fps) in DX11. Disabling DXR dosent seem to affect that. Unlit ja wireframe also have the fps hit. Having tessellation disabled too. :S

Edit: Landscape painting also is bugged. Cant almost draw any layers, only some appear as fully painted grid pieces. And there is no visible paint-sphere. If replacing landscape material with basic material without layers then FPS gets good again.

Also there is no stat font.

destruction demo not working from the launcher https://www.youtube.com/watch?v=msvjJbRsUp0

also content examples wont download for 4.23 but is showing in the options

I’ve got incredibly dark lighting now after upgrading a project to 4.23. Scene before was very bright, too bright if anything, now i’ve got this. Believe it or not theirs a BP_Sky_Sphere up there that should be bright blue

try installing to c:\unrealengine
you can’t use long paths like c:\Windows\users
ame\documents\unrealengine etc…

have you tried rebuilding lights?

Yes, afraid this was the result after light build

I’m not having any issues with arrays. however tmaps blow up the editor like a nuke

try deleting the skysphere and re add it and the directional light.

Well i feel like a bit of an idiot now.

Wasnt anything to do with lighting, or even 4.23 at all. My datasmith import is bringing in something called “Global Exposure” from Max now, which is applying a post process that destroys the brightness in the scene. Getting rid of that returned me back to normal. Thanks for trying to help out :slight_smile:

I’m having structs in the arrays. But I’m pretty sure it is a problem of the editor and not the engine. All arrays work as intended when I run the project. I just can’t edit or create new array elements in the editor. So there is still hope ;).

I had one array that threw an error message out. So I investigated and it turned out it contained 82 elements while I entered only 2. There was no loop or anything so I added a ‘clear’ at the start of the node network before adding elements. Then it worked fine. The 80 ghost array elements disappeared. Something weird is going on in the editor only.

Arrays of structures

About the Chaos Demo, it won’t work from Launcher just after download. You need to follow the “new” instructions point out by VictorLerp and build the Chaos Demo along with the Engine from source, and at the document they said you have two options to start the demo: 1) running it inside Visual Studio or 2) double-clicking the .uproject file at Windows Explorer. The second option failed to me, but the 1st one worked so far.