Unreal Engine 4.20 Released!

For some reason it just took like 10 mins for my firewall to pop up and ask me to allow the software to launch. Weird, but it’s working now.

Converted project from 4.18.3 to 4.20 today and am getting error during packaging, this project packages fine on 4.18.3. I saw someone post this error in the 4.20 preview but never saw a response any help would be very much appreciated. I did do a test on FPS template project and 4.20 worked fine I just don’t know what changed between versions to cause this to happen on my project.

UATHelper: Cooking (Windows): LogInit: Display: LogObj: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False

Thank you!

Thanks for your answer. I started a whole new project in 4.20, there is nothing I took from the previous version. I compared the settings of the “old” and new BPs, they are absolutely the same.

Am I the only one not able to get a projectile to bounce?

Edit : Nevermind, I found the issue, my static mesh was not the root of my BP and, therefore, the projectile was not working as expected. Sorry for the mess :stuck_out_tongue:

From my understanding it allows you to make gameplay tag containers only allow selection of tags in a specific subsection. Like weapon tags HAVE to start with Equipment.Weapon etc.

Hey guys, I downloaded 4.20, installed and lauched the Games Launcher but there is no button to install UR 4.20, just the orange Launch button for 4.17 and 4.19. How do I install 4.20?

Click on the Plus sign next to engine versions. Select 4.20 for the new launcher item.

I found the WinX and WinY setting for each node :smiley: so it works under fullscreen mode to put in different monitors.
Just if I want to set lower the window size and put all the nodes on one screen for testing, still have no idea.

Tried the nDisplay XD It’s a great feature! Looking forward for the beta release :smiley: I’m trying it on one PC, and a problem currently is that it’s fullscreen by default, so if I have several monitors on one PC I have no idea how to move the different node screens to different monitors…

Not seeing a plus sign anywhere, or in the pulldown…see pic

You need to go to your library :slight_smile:

And apparently how to upload images. :slight_smile: Thanks Kvogler, for the assist

I can’t get this^ to do anything, following the instructions in the release notes.

  1. I enable the Editor Scripting Utilities plugin, restart the editor
  2. Make a blueprint of class ActorActionUtility (or AssetActionUtility)
  3. Make a function or event in it with Call In Editor = true
  4. Override the GetSupportedClass function (though it seems like thats optional)
  5. Right click on a supported actor (or asset) - nothing?

Am I misunderstanding “Context Menu”?

Error when building for iOS from Mac

UATHelper: Packaging (iOS): LogObj: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False
PackagingResults: Error: LoadConfig (/Script/Engine.Default__RendererSettings): import failed for bEnableAlphaChannelInPostProcessing in: False


Thank you for the information. Please keep in mind that we are not taking bug reports through this forum. Please submit your bug report with as much information as you can provide using our Bug Submission Form.

So… apparently UHT is appending search paths instead of effectively “search” directories for include headers now.
Then we can omit any directory listed in PublicIncludePaths… But never omit any sub directory within them.

If a plugin’s directory path is added to PIP, for example:

PublicIncludePaths.Add( Path.Combine( ModuleDirectory, "Public" ) );

And we have a header within:

Path.Combine( ModuleDirectory, "Public/folderA/folderB" );

Now we have to specify the path in full below the ending directory of PIP (“Public/” in this case):

#include "**folderA/folderB/**MyHeader.h"

While previously we could just tell UHT to search for it within any PIP folders, like:

#include "MyHeader.h"

Fine, I think it’s fair and logic change… but annoying headache fix for soooo many #include directives I have to fix now =

I saw that mentioned a while ago in the commits, they were getting more include paths than some compilers could handle and decided to cut everything off at the Public folders to fix it

The problem is that if you place the engine source in a really deep path (C:\Development\GameEngines\UnrealEngine4\Latest\Engine…) then when compiler tries to compile source code, UBT will add all the include paths to a .response file used as input by the compiler. The max .response file for Windows (when compiling with symbol information) is 64K. Having the really long explicit path to all include folders in the .response file can easily cause it to exceed 64K in size. Having a shallow path (C:\UE4\Engine…) will prevent this, but not everyone has things set up that way. So now, instead of adding all sub-folders for a module/plugin to the .response file as an include path, UBT only adds “Classes” and “Public” folders and you have to modify the #include statement to specify the rest of the path to your .h file.

Ok, I am crazy or Niagara makes some basic stuff super time consuming? To create a simple particle with 3 emitter you need:

• Create a Niagara System
• Create 3 Niagara Emitters
• Add the 3 Niagara Emitters inside the Niagara System

And if I need to add 1 more Emitter I need create another emitter outside the Niagara System and Add it to the the System.

Add a way to create Emitter inside the Niagara System that go inside the Niagara System folder. Them you create a Niagara System and add 3 emitters inside the system.

In trying to step up to 4.20 from 4.19 we discovered that we can no longer use our custom online subsystem plugin due to changes made in how FUniqueNetIdRepl is serialized with the new encoding scheme.

When trying to connect client and server we are getting an “Error with encoded type hash” message. Digging into this we found a change in the FUniqueNetIdRepl::NetSerialize method that now uses new methods on the online subsystem utils class to convert a hash value to a subsystem FName however there is no way currently to inject a new subsystem to hash mapping for custom plugins.

Is this intended behavior, an oversight or are we missing something with how to add a new custom online subsystem plugin since the 4.20 change?



I’m game designer of a project made with the asset “Paragon: Minions” and it isn’t compatible with 4.20. The heroes assets are compatible, but we never planned to use them.

Would you recommend us to wait for a compatibility patch or stick with 4.19.2?

We just finished the presentation and send it to the Unreal Dev Grant, it’s a big issue for us! As you can see, we worked really hard the last 2 months and we had almost finished a prototype for Kickstarter:


What is wrong if new Feature on Opegl ES 3.1 , Hardware Occlusion? it seems it will hide quite easily everything a bit far from center of camera view, can we somehow control this? (Snapdragon 820) , Android Oreo .

EDIT : i will add that it seems that it occludes meshes based on their screen size, which its quite obvious when pitching up/down the camera while centered on the object…

it requires something to change so it behaves like pc ( or near as pc) or it is just bugged?