Download

Unreal Engine 4.20 Preview

I appreciate have an opportunity to test 4.20 (now on preview 4) but it is frustrating to have no notes or sample maps to test features like Proxy meshes or Mixed Reality Framework. For instance, for the Proxy tool, I don’t see any limiting factor notes and it seems to crash on larger static meshes, or was it because the static mesh used displacement?

The Mixed Reality Framework seems less complete than 4.18 with no actual calibration map or function. Also, in the 4.20 P1 version notes, you state that there is a list of compatible cameras, yet in searching I could not come up with one. In my own test, the Logitech C920 works, but my Magewel USB3 HDMI (GEN 1) does not. The MrcVideoSource function sees it and gives me the correct video input of ‘YUV2,1920x1080 60 FPS’ which I have been able to create an instance of M_MrcVideoProcessing and tweak it for my green-screen background, but as soon as I do a ‘VR Preview’ it switches to NV12 640x460 50fps and video freezes, but the rest of the VR experience works normally. There also seems to be an aspect error issue as well, that was not seen in the Logitech C920 video output.

it might be related to this: https://forums.unrealengine.com/unreal-engine/feedback-for-epic/1457519-4-19-4-20-editor-packaged-games-have-hangs-hiccups-constantly

The fbx, importer on 4.20 isn’t working it just crashes or says unable to load file, just a heads up.

That’s an abstract class and is likely designed for Blutilites rather than Python (it looks like you’d need to derive from it as it’s a non-static function so it’s expecting a “self” argument).

You could try this (untested), which is gross, but I don’t know if there’s another way to get the Content Browser selection right now.


@unreal.uclass()
class MyEditorUtility(unreal.GlobalEditorUtilityBase):
    pass

editor_util = MyEditorUtility()
editor_util.get_selected_assets()

FWIW, the Python “help” command works for our types and will tell you things like their expecting signature, and you can always expose any functionality that is missing by writing custom UFUNCTIONs for it.

That did indeed do what I needed. Thank you so much! I still have a lot to learn, but glad to be learning every day! :slight_smile:

Narrowed it down to the same line as you AtsK. I went to build the engine to check exactly what it is using the 4.20 branch and the issue seems to be gone? Fingers crossed everything works fine in the next preview.

Also I have a feeling this is not the same issue as people are having over in the other post below as I have had no issues at all with 4.19, is that the same for you too Atsk?: 4.19 & 4.20 Editor & Packaged Games Have Hangs/Hiccups Constantly - Unreal Engine Forums

niggers suck fat dick

I’m running into the following error when I try to run a packaged build made with preview 4:


Assertion failed: !GEventDrivenLoaderEnabled [File:D:\Build\++Shared\Sync\Engine\Source\Runtime\Core\Private\Internationalization\TextHistory.cpp] [Line: 1276] 

It’s possible this also occurred in previous previews but due to a different bug I wasn’t actually able to successfully package my project until preview 4. Turning off event driven loading does fix the problem but my understanding is that it improves load times (though I couldn’t find anything definite about this so I may be wrong) so I’d like to keep it enabled if possible.

I’d like to make an official bug report for this but I have no idea where to even start working on a repro case so if anyone has any suggestions/guidance I’d love to hear it. Thanks.

I Agree! Please fix the nvidia hang bugs! :smiley: :wink:

I don’t know who was able to report this for the Mixed Reality Framework plug-in (I am assuming that is what MR means), but I have not been able to find any of the calibration tools or the calibration map from 4.18. I also noticed many of the function calls have been renamed so you cannot use the 4.18 calibration map either. Regardless, I have been able to stumble through locating the Mixed Reality Camera actor and put together a very unpolished tutorial of setting up a camera in your map and then assign a webcam and adjusting parameters for green screen use. However, I still have figured out why I cannot use my Windows Media compatible Magewell V1 HDMI->USB-3 converter. :frowning:

https://youtu.be/y6R0FGrAyXU?t=3611

Hey, this is a known issue and the assert has since been removed. It seems that in some cases EDL can become enabled between the Serialize call, and the call that attempts to process the deferred load action.

Does this mean we can build against C++17? I’m including some third party libraries that use


std:optional

in their interface but building still fails under 4.20 Preview 4.



fatal error C1189: #error:  class template optional is only available with C++17


Any way to make this work? Perhaps passing /std:c++17 to the compiler?

EDIT: So I realized I can probably pass the flag in via the TargetRules’ AdditionalCompilerArguments field, but this requires a Unique build environment. When I set the build environment to ‘Unique’ like so (but make NO other changes);


BuildEnvironment = TargetBuildEnvironment.Unique;

My build fails with;



1>UnrealBuildTool : error : System.IO.DirectoryNotFoundException: Could not find a part of the path 'C:\_Development\Repositories\rtg\UE4\rtg_client\Intermediate\Build\Win64\rtg_clientEditor\Development\Launch\Launch.precompiled'.
1>                           at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
1>                           at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
1>                           at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
1>                           at System.IO.StreamReader..ctor(String path, Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize, Boolean checkHost)
1>                           at System.IO.File.InternalReadAllText(String path, Encoding encoding, Boolean checkHost)
1>                           at Tools.DotNETCommon.JsonObject.Read(FileReference File) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\DotNETCommon\DotNETUtilities\JsonObject.cs:line 50
1>                           at UnrealBuildTool.PrecompiledManifest.Read(FileReference Location) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\System\PrecompiledManifest.cs:line 37
1>                           at UnrealBuildTool.UEBuildModuleCPP.Compile(ReadOnlyTargetRules Target, UEToolChain ToolChain, CppCompileEnvironment BinaryCompileEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildModuleCPP.cs:line 425
1>                           at UnrealBuildTool.UEBuildBinary.SetupBinaryLinkEnvironment(ReadOnlyTargetRules Target, UEToolChain ToolChain, LinkEnvironment LinkEnvironment, CppCompileEnvironment CompileEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:line 593
1>                           at UnrealBuildTool.UEBuildBinary.Build(ReadOnlyTargetRules Target, UEToolChain ToolChain, CppCompileEnvironment CompileEnvironment, LinkEnvironment LinkEnvironment, List`1 SharedPCHs, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildBinary.cs:line 196
1>                           at UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List`1 OutputItems, List`1 UObjectModules, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph, EHotReload HotReload, Boolean bIsAssemblingBuild) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\Configuration\UEBuildTarget.cs:line 2323
1>                           at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String] Arguments, FileReference ProjectFile, Boolean bCatchExceptions) in D:\Build\++Shared\Sync\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\UnrealBuildTool.cs:line 1480
1>                        (see ../Programs/UnrealBuildTool/Log.txt for full exception trace)
1>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command ""C:\Program Files\Epic Games\UE_4.20\Engine\Build\BatchFiles\Build.bat" rtg_clientEditor Win64 DebugGame "C:\_Development\Repositories\rtg\UE4\rtg_client\rtg_client.uproject" -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command.
1>Done building project "rtg_client.vcxproj" -- FAILED.


I’m using a binary build of the engine, not my own built from source. Could this be a reason?

I definitely think the Mixed Reality Framework needs to be setup and documented in a way that its nice and easy to use. Twitch streamers that stream a VR game have to be able to get their camera into there (and have it calibrated correctly) with a few minutes of work, otherwise they won’t do it.

So Epic, please make sure there is proper documentation for that!

Packaging plugins always fails with a warning about the Expat lib and then an error about the module’s “.precompiled” file not being found in the host project. Actually, while checking if it was there, I found that not even the Development folder was created inside Intermediate. I don’t know if the Expat warning and the precompiled error are related.

The warning and the error are always the same, for both Android and Win64 (of course the paths have platform variations). The project is set to use the VS2017 toolchain and VisualStudio version is 2017 15.7.4

This is the warning:
[FONT=courier new]UATHelper: Package Plugin Task (Windows): C:\Program Files\Epic Games\UE_4.20\Engine\Source\ThirdParty\Expat\Expat.Build.cs: warning: Referenced directory ‘C:\Program Files\Epic Games\UE_4.20\Engine\Source\ThirdParty\Expat\expat-2.2.0\Win64\VS2015\Release’ does not exist.

And this is the error:
[FONT=courier new]UATHelper: Package Plugin Task (Windows): ERROR: System.IO.DirectoryNotFoundException: Could not find a part of the path ‘A:\Libraries\Documents\Dev\Unreal Projects\EditorToolsDev1\Package\VillaniBlutilityExt\HostProject\Plugins\VillaniBlutilityExt\Intermediate\Build\Win64\UE4\Development\HISMActorExt\HISMActorExt.precompiled’.

Thanks for that! I found an issue but it was about your first complaints (wrong root folder), and it seems to have been solved. Hope this one also gets solved in the next preview. Voted.

I thought I saw it mentioned in a GDC talk that Epic would release the streamer they built for the ILM Xlabs raytrace demo for streaming to the Ipad to the general public in 4.20. Is this still in the plan? I don’t see it on the list.

Ok, that is encouraging, thanks!
And no I have not encountered any freezing in 4.19.

UPDATE!

We have just released Preview 5 for 4.20! Thank you for your continued help in testing the 4.20 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

For a list of known issues affecting this latest preview, please follow the links provided on the first post in this thread.

Fixed in Preview 5
Fixed! UE-60538 Engine Test - Screenshot ‘AnimatedCloth’ test failed, Screnshots were different!
Fixed! UE-61299 Audio mixer memory leak
Fixed! UE-61303 Clicks with stopping voices in QAGame
Fixed! UE-61128 Synth Sample Player Crash When Setting Sound Wave During Playback On Long Files
Fixed! UE-60850 Stuttering audio when playing Short Beep sample
Fixed! UE-60913 Static sounds have severe hitching of sound in New Audio Engine on HTML5
Fixed! UE-60839 Audio is inaudible when Falloff Distance is set to 1
Fixed! UE-61309 CircularQueue Count method returns bad value when Tail wraps around
Fixed! UE-61058 Visual Studio not linked to Binary Editor
Fixed! UE-60726 Error occurs when attempting to create a local binary engine build that includes iOS
Fixed! UE-60969 UAT searches wrong root folder for include paths specified in .Build.cs
Fixed! UE-60962 Enabling a plugin in a BP project does not compile the plugin on restart
Fixed! UE-61182 Mac Core Components is 17GB with Preview 4
Fixed! UE-61249 Lighting needs to be rebuilt in ContentExamples - Lighting
Fixed! UE-60678 Disable FX option doesn’t disable all the sound FX
Fixed! UE-60673 Lots of clicking in ambient audio on Android
Fixed! UE-60583 Main menu doesn’t fade behind Options on Android
Fixed! UE-60953 Class Type References are listed twice in the description for Virtual Reality Templates
Fixed! UE-60943 Potions do not provide the recovery listed in the inventory
Fixed! UE-61142 ContentExamples - Lighting - 5.4 example needs to be updated to use SpecularScale
Fixed! UE-61120 Replace VirtualCameraSample project with VirtualCamera project
Fixed! UE-61147 Multiple unused assets and Redirectors in EngineTest
Fixed! UE-61082 Match3 fails to package for iOS with Binary Editor and Source build - bCompileCEF3
Fixed! UE-60658 iOS packages fail to build with incompatible Datasmith plugins
Fixed! UE-60937 Texture need to be reimported after importing MDL file
Fixed! UE-61157 nDisplay template have some bad settings
Fixed! UE-59042 Late feature : VRed importer
Fixed! UE-60946 Import CAD - Crash on reimport Datasmith scene after deleting light sources
Fixed! UE-61132 [Regression] Missing static mesh actors on importing CATProduct
Fixed! UE-61178 Media Bundle Scaling Issues
Fixed! UE-61102 ActorComponent.h BP Node Tooltip Typo on bReset
Fixed! UE-61156 Code projects fail to compile in Binary version of the editor - NavigationSystemBase.h(202): error C2143: syntax error: missing ‘;’ before ‘<class-head>’
Fixed! UE-60922 Nav Area class is reset after updating from 4.19.2 to 4.20 Preview 3
Fixed! UE-60924 The target for the “Should be Loaded” variable appears to have change to “Level Streaming Kismet”
Fixed! UE-61123 Text pins on call nodes not updated when default value changes
Fixed! UE-52940 Two nodes named Load Level Instance
Fixed! UE-61088 Text pins are not orphaned when it has a value
Fixed! UE-59040 Crash when calling a RPC function with a TSet or TMap parameter on a client
Fixed! UE-61003 DemoRec creates named folder demo2 instead of the expected demo1 named folder for empty Demo directories
Fixed! UE-61033 ShooterGame: Unable to return to Main Menu from Demo Replay
Fixed! UE-61031 Shootergame Demo List persists after Demos Start Playing
Fixed! UE-61181 Crash opening Physics Asset for a clothed skel mesh with assigned LOD Settings
Fixed! UE-61191 TLS slots can be shared due to issue with TStaticBitArray::FindFirstClearBit()
Fixed! UE-60993 Shootergame fails to build with LogShaderCompilers: Error: Errors compiling global shader FPostProcessDiaphragmDOFSetupCS
Fixed! UE-58827 TM-ShaderModels launch on process terminates with no logging after approximately 2 minutes
Fixed! UE-61121 ARM server fails to link missing openexr files
Fixed! UE-61115 Linux: Mono Process from UBT runs in the Background after Package is Cancelled
Fixed! UE-60879 Setup.sh does not automatically restart on Ubuntu 14.04
Fixed! UE-56041 Linux: Cancelling a package during build command prevents another package from being run
Fixed! UE-61190 UnrealMatch3 crashes when rotating while opening on IOS
Fixed! UE-60738 RemoteSessionApp is missing updated app Icons
Fixed! UE-58683 Custom iOS icons don’t appear on device for Windows BP projects (Binary Build)
Fixed! UE-58081 ARKit face AR - native orientation is Landscape, needs to match app
Fixed! UE-60928 RemoteSessionApp project fails to compile
Fixed! UE-59576 Blending on meshes in Landscapes umap is not rendering properly in High End Mobile Preview or HTMl5
Fixed! UE-59931 Blueprint iOS apps are named UE4Game.ipa
Fixed! UE-54781 Preache request should have been hot warnings opening QAGame
Fixed! UE-60605 Using the old DOF algorithm doesn’t work properly
Fixed! UE-60747 Basic StaticMeshActor components render discolored when undoing duplication
Fixed! UE-60764 [CrashReport] UE4Editor_Renderer!FMaterialShader::SetParametersInner<FRHIVertexShader * __ptr64>() [shaderbaseclasses.cpp:181]
Fixed! UE-60440 Infiltrator demo has very bright lighting on Mac
Fixed! UE-60425 Lights are not alternating their reaction on Lit Particles
Fixed! UE-60328 Translucency Lighting mode examples flicker in TM-ShaderModels
Fixed! UE-60380 Crash when running Editor with -vulkan - Error: Runnable thread RHIThread crashed.
Fixed! UE-60358 Animated Cloth rendering incorrectly in TM-ShaderModels - Mac Intel Iris Pro 6100
Fixed! UE-60169 [CrashReport] UE4Editor_Renderer!FMaterialShader::SetParametersInner<FRHIVertexShader * __ptr64>() [shaderbaseclasses.cpp:181]
Fixed! UE-60191 Launch-on and packages of TM-Shadermodels for iOS fail from missing Shader Maps
Fixed! UE-60965 Crash when setting the ‘Color Vision Deficiency Preview Type’ to anything other than Normal Vision on Mac
Fixed! UE-61106 Mac ComposureFramework project crashes on launch, Assertion failed: BufferIndex < 8
Fixed! UE-61105 GitHub 4829 : 4.20 dynamic hidden shadows fix
Fixed! UE-59505 Photorealistic Character aliasing results in jagged lines on skin and blotchy hair
Fixed! UE-57663 Vulkan crash when PIE in QAGame, vkGetQueryPoolResults failed with error VK_ERROR_DEVICE_LOST
Fixed! UE-52759 SwarmCoordinator and SwarmAgent can randomly fail writing to output directory in race condition during build
Fixed! UE-60964 Sequence Recorder Recording Groups have a “_A” appended after the user renames them.
Fixed! UE-61015 Control Rig Sequence doesnt have a default display rate
Fixed! UE-60991 Render movie settings not inheriting launch arguments from the editor
Fixed! UE-60976 Actor to Record in Sequence Recorder isn’t Filtering by Assets in the Level
Fixed! UE-61036 Crash when exiting a Sequence Recording in PIE if the Sequence Recorder window is docked to the left side of the editor
Fixed! UE-61074 Exposed default level sequence instance data to game C++
Fixed! UE-59820 Crash garbage collecting after saving a sequence with a duplicated binding
Fixed! UE-57712 Sequence Recorder: the sequence name of next sequence is not updated with next iteration when recording begins
Fixed! UE-61170 MeshDescription.Conversion test fails converting RawMesh to MeshDescription to RawMesh
Fixed! UE-60500 Staticmesh LODs custom SectionInfoMap give a different material mapping, build versus load
Fixed! UE-60301 The user is not warned when using content with broken normals due to encoding changes
Fixed! UE-61001 White frames on startup movies PC and XB1
Fixed! UE-61108 [CrashReport] UE4Editor_UnrealEd!FAssetEditorManager::OpenEditorForAsset() [asseteditormanager.cpp:386]
Fixed! UE-60952 Hovering Curve Gradient stop areas after creating a stop with Opacity = 0 hides the Curve Graident
Fixed! UE-61092 Startup Movies Black Screen in Packaged Projects
Fixed! UE-61085 High DPI Monitors and Editor Ruler
Fixed! UE-61098 //UE4-Release-4.20 - Incremental EngineTestEditor - warning: field ‘bUseMouseForTouchInEditor’ will be initialized after field ‘bShowTitleSafeZone’
Fixed! UE-60485 Removing a Foliage Type from a ProceduralFoliageVolume does not remove the Foliage Type from the volume when it is placed in a level
Fixed! UE-60958 Undoing and redoing erasing foliage will cause the foliage to flicker in the editor
Fixed! UE-59598 ContentExamples - SK_Box_Morph_1 has artifacting when animated
Fixed! UE-59611 Reimporting Static Mesh LODs yields unexpected material assignments
Fixed! UE-60549 LandscapeGrassOutput node doesn’t have name fields for Grass Types
Fixed! UE-58338 [CrashReport] UE4Editor_MaterialEditor!FMaterialEditorParameterDetails::GetParameterExpressionDescription() [materialeditordetailcustomization.cpp:365]
Fixed! UE-61241 Data interfaces defined in an emitter script can’t be used in a particle script in the emitter editor.
Fixed! UE-60688 Crash when deleting user exposed variables in system when created with parameter map
Fixed! UE-60390 Crash compiling Niagara Module script with a Curve Input Parameter
Fixed! UE-60995 [CrashReport] UE4Editor_NiagaraEditor!FNiagaraEditorUtilities::GetScriptOutputNode() [niagaraeditorutilities.cpp:823]
Fixed! UE-61087 Assert undoing the removal of an Emitter from a Niagara System with multiple Emitters
Fixed! UE-61012 Keeping Niagara GPU simulations open in the background causes the system to run out of virtual memory
Fixed! UE-61010 Editor crash when dragging Niagara Modules from one Emitter/System Stack to another
Fixed! UE-61037 ~10ms slow down when running with -game
Fixed! UE-60182 Button color does not change immediately when a material is applied
Fixed! UE-61287 Failing to launch on to Lumin device due to vulkan RHI issue
Fixed! UE-61204 ARCandidateImage and ARCandidateObject are missing Blueprint accessible APIs
Fixed! UE-60582 Mac: Daydream Instant Preview Encounters Handled Ensure On First VR Preview of Editor Run
Fixed! UE-61168 Crash when using remote live link publishing of face ar data and using xcode version < 10
Fixed! UE-60963 Failure to launch onto Magic Leap due to Shader Compiler issues
Fixed! UE-61148 Removal of bSupportAR causes the host to not start all the proper channels
Fixed! UE-61067 ARSkyLight defaults to having the lower hemisphere be black
Fixed! UE-60875 Lumin - Need to disable the “All_Phaedra_On…” Launch on option for 4.20
Fixed! UE-58385 FaceARSample - Looking for face to track prompt does not come up if tracking is lost while app is running
Fixed! UE-61207 nDisplay template icon does not fit well with other template icons

REMEMBER: Please report any new bugs you find by following the How To Report a Bug Guide

Hi, i’m newbie in ue4 and have no Mixed Reality Capture Framework C++ Classes in my content browser (plugin enabled) in UE4.20 Preview 4 and Preview 5 for MacOS. How can i fix this?