Unreal Engine 4.11.2 - Pixilated boot screen, and then engine fails to load.

Hi,

I’m having trouble with version 4.11.2 of the engine.
I updated yesterday, and upon launching after the update had finished, the screen where you select the templates was pixilated and illegible.
by clicking around I managed to launch the engine, but upon launch, it failed to load and issued an error that the program couldn’t launch.

I was wondering weather anyone else had experienced this or knew what to do.
I’ve re-installed this version on the engine and it still doesn’t work; other versions work fine, though.

Thanks allot!

Bump

Thanks :slight_smile:

Have you tried restarting the system?
Have you tried verifying the installation?
Does manually launching the “.uproject” project work?

Could you post the log file (I don’t know where that is on Mac/Linux, But on Windows it is at “C:\Users<USER_NAME>\AppData\Local\UnrealEngine<VERSION>\Saved\Logs”)

I have had it twice where a system restart was all that was needed.

HTH

Hi,

Sorry for the late reply - I’ll try the above and report back.

Restarting hasn’t done anything, and I’ve tried launching a .uproject and it just said unreal engine had crashed.

Not sure what you meant by verifying the installation. I have reinstalled the new update twice and still got nothing.

As far as the logs, I’ve been searching for a while and I can’t seem to find them. I’ll keep looking.

Thanks!

One of the options for the drop down arrow on the engine version is “Verify”.

My log files are located “C:\Users<USER_NAME>\AppData\Local\UnrealEngine<ENGINE_VERSION>\Saved\Logs”
And then for the project logs “<PROJECT_FOLDER>\Saved\Logs”

Is the project C++ based or have a C++ solution?
If so: You could load up the solution and use the IDE to start the engine and see where the debugger brings you when the crash occures.

HTH

Verifying didn’t seem to work, and I still can’t seem to locate the log files. :mad:
Interesting idea with the debugger - I’ll try that and see if it works.

I’ve noticed a new update has become available, so maybe that one will rectify whatever problem is present.

Thanks again

Are you on Mac/Linux?
Do you have a high DPI screen

The path to the engine logs is for Windows Vista+, You will have to find the Mac/Linux equivalent of the AppData folder.

HTH

The equivalent to the appdata folder from windows is, I presume, the application support folder.
oddly, there is no folder for either epic games or unreal engine in that folder, as there are for all the other apps on my system, so I’m not sure. I’ll find them eventually.

what would you class as high DPI?

I upgraded the engine to 4.12.0 today and the same issues persisted.
however, I also received a message that I hadn’t seen before.

It stated that my graphics card can only run an older version of OpenGL, and that a newer version of openGL is required to run unreal engine to any appreciable level.
So perhaps this is what’s causing the problem.
My graphics card is only the stock one that came with my mac pro - obviously no where near what is required to run the engine efficiently, but as a beginner, it was okay as in previous versions the engine booted and I could play around in it; albeit at a terrible resolution.
I’ve of course always planned to upgrade as I got into it more and I think now I’ll have to do so anyway to even run the engine, if this is the issue.

Thanks allot.

I see there is a page here that describes where the different logs should be.

Can you find what GPU you have and driver version?
I believe UE4 can use the Metal API on newer versions of Mac.

Unforntunetly, I don’t think there is much else that can be done to debug the problem.
Other then making sure that you have the latest GPU drivers or trying to run the editor on another computer.

HTH