Download

Unreal doesn't see textures while importing, white textures.

Hello everyone, I have a problem here. I can’t import in Unreal my models correctly.
To understand the situation better, I will describe all steps that were taken.

  1. Firstly, I made a model in Zbrush, I made there polypainted textures and made UVs.
  2. Then I used GoZ function, which imports this model to Autodesk Maya. All textures are visible, everything is fine.
  3. I combined all meshes (subtools) in one. Then I deleted history by type and freezed transformations, exported selection in FBX format 2013 (because it’s a Mixamo requirement), activated the Embed Media option to save textures (thought, it would help).
  4. Textures are messed up in Mixamo (black parts of body), I paid no attention to it, because it doesn’t affect the result. It’s normal to Mixamo.
  5. Finally, I import the animation to Unreal. All import settings are default. But after this my model is just white, all textures are gone. I tried importing textures separately after this step and connecting them in material, but they don’t see UVs.
  6. Also I tried other import setting, without creating new materials, just importing textures. It didn’t work.
  7. The point is, after all these actions done, I imported the animation in Maya and all textures were fine! I don’t understand, where is the problem. Textures are Lamberts and they must be included in FBX file.

This issue is pretty urgent. I will be very happy to receive any answers and solutions, this is my college project and I don’t want to lose all the hard work.
Needed screenshotes are attached.

P.S. Sorry, if I am writing this in wrong forum section, I’m new here.