Download

Unreal 5 - It takes to long to compile shaders

I love the blueprint coding language. For the first time in my life I think I can understand coding.

But any time I try to strike out on my own and do anything in U5, not following a step-by-step game making tutorial, I keep running into a shaders compiling forever problem.

It’s like your are pretending to be user friendly but still filtering out potential game creators by making us jump through impossible hoops.

You need to setup your swarm agent to run shader compiling to a higher cpu priority.

or you can go into task manager find shadercompiler.exe in details tab and set its priority to normal, as for some reason it starts with priority below normal. Doing this will decrease compile time, however setting it higher can cause older less powerful cpus to run at 100% usage making it lag on other programs so use your best judgment depending on the speed of your cpu etc.