Unexpected program state internal error MSS_STR001

Has anyone faced this error before? Unexpected program state internal error MSS_STR001 (attached image)
When I try to process 600 24.3MP images taken from 1.8 m height, I get this error message near the end of the alignment process.

With the same setting and conditions and images, I did the alignment before. But this error starts up from today and continue every time. 

anyone have an idea about this?

Thanks

Hello MD NASIM REZA,

do you have this problem only with this dataset? Have you changed the alignment settings?

Can you please check if some of the images are not corrupted? Can you please try to process small sample of images if that is working OK?

Thank you Zuzana Ďuríčková CR for your Reply.

Yes, the problem is for all data sets not only this one. Actually, there are some data sets, which the RC worked properly, but from yesterday it didn’t.

I also tried different alignment settings, but still the same condition.

I checked all the images, all are alright, not corrupt files. 

I tried with small samples like around 100 images, only that time it works, but in that case, I did not get my desired 3D reconstruction.

Thanks.

 

 

Please try to clear the cache, reinstall RC (you can launch RC with holding shift key and choose Make it like a clean install) and try again. 

If the problem persists, would it be possible to share with us the exact alignment settings you used and the smallest sample of images that is causing the problems? You can send us the link for download via our contact form. Also what are your HW and OS specifications? Thanks.

Thank you Zuzana Ďuríčková CR for your Reply.

I tried clear the cache, reinstall RC. But it didn’t work for me.

My alignment settings are here (attached images). With the same setting, It worked before. 

Actually, in my image set, there are three different view angle images. 90 degrees from the top (144images), 60 degrees from the top (203 images)and -60 degrees from the top (277images).

When I separately tried, 144, 203, 277 images to align it worked.

But When I try to do it from first 200 images it did not work and showed the error.

All Images link are here:

https://1drv.ms/f/s!AkiMezhLnO0ghB9leMVrSkBw5AR8

Hardware and Software Specification:

OS: Windows 7ultimate (sp1) (64bit)

Processor: Intel Core I7-7700CPU @3.60GHz 

RAM: 32 Gb

Storage: 250 Gb (SSD); 1TB (HDD)

Please check the RAM usage and the free space on the cache disk. You have changed the values for detected features to very high values, I believe so many features will not be detected anyway. Try to lower those values to more reasonable values and align again.

I will download the data and take a look at it as well. 

Hello,

thank you for sending the data, we were able to reproduce the problem. I will get back to you once we find out the reason of this behavior. 

In the meantime please try to align first batch of images, add another batch, align again etc. Seems that in such case the error does not appear. 

Thank you Zuzana Ďuríčková CR for your Reply.

I shall try your suggestions. And please let me know about the problem.

I just hit the same error. Yes. It looks like the issue is in my images.

I think that there are just too many images, that look the same. It is a processes video from the drone. It has a few moments when the drone just hover. I will try to delete them later on and see what will happen. As I managed to build the same model from the smaller data set. 

Yeap. Works just fine on smaller set 12fps out of 25fps. Was crashing when I was exporting images in 16fps ratio.

I will delete some later, that look the same and re-run it.

I just worked in Support. I love to crack things like that.