Unable to launch project on iOS built by UnrealRemoteTool

Unreal Engine 4.7.5

iOS 8.3

OS X 10.10.3 (VM)

I followed “Steps for IOS build with UnrealRemoteTool” and I am able to build (test.stub) and deploy to my iPad3. However, nothing happens when I run it (just black screen).

See this line in Xcode console log:

Apr 11 18:11:35 iPad3 test[921] : Assertion failed: HasFoundDataDirectory [File:/UE4/Builds/LYNNFIELD/D/UE4/Engine/Source/Runtime/Core/Private/Internationalization/ICUInternationalization.cpp] [Line: 118]

ICU data directory was not discovered:

Looks like it is causing the problem. Can anyone tell what is going on?

I can see that both test/Content(PC & Mac) are empty. Engine/Content is empty on the Mac but has files on the PC.

The console log and 2 crash log files are attached. log.zip

If you are running from xcode you will need to get the content to the device. Easiest is cook on the fly server running on your PC. You can do it with UFE or Game Launcher in the editor, or the command line:

Ue4editor-cmd -run=cook -cookonthefly [-iterate]

Then add this to the ios commandline in xcode to -filehostip=X.x.x.x

(using your PC ip address)


Thank you for your reply. I tried both “Package Project” and “Project Launcher”; they both failed. I can see from the attached log files that UnrealBuildTool failed (line 572 of UAT_Log.txt). Did I do something wrong?


Josh is right, you need to either package the project so it cooks the content, or use the cook on the fly server. However, you have a more fundamental issue in that you named your game project “test” A couple of our tools see that in the command line and believe you are attempting to build the test configuration. Try naming the project TestGame or something similar and give that a go.


Thanks a lot Pete. It works and you just saved my life.