Unable to download the U4 Engine

Getting the following error:

Firefox can’t find the file at https://download.epicgames.com/Builds/UnrealEngineLauncher/Installers/EpicGamesLauncherInstaller-2.0.1-2467307.msi.

I’ve tried several times in the last hour.

Thanks!

I am getting the same error. I am not sure why.
Does anyone have an idea?
Thanks!

Hi folks!

Sorry about this. We just made a change a short while ago that should fix this. Can you re-try?

-Tyler