Download

Unable to connect a client to a listening server over two networks?

Hello,

I am having some problems with networking.
I am working on a project together of a friend of mine (separate networks).

We want to create a level where the both of us can connect to the same level at the same time, where one user is the listening server, and the other user is the connecting client.
The first disclaimer is that I am operating on Win64, whilst my friend is on MAC OS. Apparently this should not matter, as they should be cross-compatible.

The first test we did was to have one of us package the FPS example level project which can be found in the new projects section.
We both did this and made no further changes to the level. We packaged this level to our respective platforms.

We both tested our packaged project locally between two of our own machines. I tested connecting as a client to my listening server (desktop to laptop) and it works fine.
He tested the same thing but between two MACs. This also worked fine.

However, when we try to connect to each other (where one is the listening server) the client will always get a closed connection (this is seen in the log).

We thought it was a firewall issue at first, but it doesn’t seem to be the case. Anyone know how to make this work, or point us in the right direction?

Thanks.

EDIT: It is worth mentioning that the one of us attempted to open all ports temporarily to let the client connect, but this did not help. The connection closed anyways.

Here is how I launched the game as listener (Host):
db7e793053ba39b5255e269b51f71c243c81da5e.png

Here is the error we get when my friend, the client, attempts to connect to my game via my public IP:
2870c2bcb1ee9a6f04a58133c335b92f92eef395.png

Any help would be greatly appreciated :).

Hey,

this is kinda the wrong Forum-Part :smiley: So I would need to know if Blueprint only or C++?
Then I it to the correct Forum-Part (:

Cheers!

Thanks for the reply!

I didn’t know where to place the thread because it is not exactly bound to either C++ or Blueprints. This is about connecting a client to a listening server via packaged projects.
We have not done any changes to code. We have also not worked with any blueprints. You can move the thread to wherever you would like, if you know where it should go. :slight_smile:

There is no network section as far as I know…

This is solved now.

We had compiled the build on two different versions of the engine. I was using 4.10.4 and he was using 4.11.1
Updating fixed it.

I hope this is useful for anyone in the future.