Download

Unable to compile plugin due to No filename provided for module

I am attempting to compile a plugin in a project that uses the uplugin file:


{
	"FileVersion": 3,
	"Version": 1,
	"VersionName": "1.0",
	"FriendlyName": "SomePlugin
	"Description": "",
	"Category": "Example",
	"CreatedBy": "",
	"CreatedByURL": "",
	"DocsURL": "",
	"MarketplaceURL": "",
	"SupportURL": "",
	"CanContainContent": true,
	"IsBetaVersion": false,
	"Installed": false,
	"CanBeUsedWithUnrealHeaderTool" : true,

	"Modules": 
		{
			"Name" : "SomePlugin",
			"Type" : "Program",
			"LoadingPhase" : "PostConfigInit"
		}
	]
}

However it fails when running UBT with the error


2>LogModuleManager : warning : No filename provided for module SomePlugin
2>LogModuleManager : warning : ModuleManager: Unable to load module 'SomePlugin' because the file 'C:/Program Files/Epic Games/UE_4.16/Engine/Binaries/Win64/' was not found.
2>LogCompile : error : Failed to initialize the engine (PreInit failed).

I am certain that the module is there and it compiles when using “Runtime”, I’ve also tried other available plugins like ScriptPlugin or projects on GitHub that use similar uplugin settings and those also seem to fail to compile with the same error output.

So then why are you trying to use “Type”: “Program”? I’m 99% certain that isn’t valid for plugin modules.

It’s not the Type causing it but the fact I need it to run with UBT. After testing yesterday, it’s an issue that only occurs when compiling the plugin with the launcher version of the engine, it doesn’t happen with a Source compile being the engine version.