UMG changing Texture look on Play (No, not the SRGB thing)

Well, looks like the imagewidget is forcing some kind of tint whatever I do on my texture…

Here is the screenshot:

Here are the tests I did:

  • Switched the SRGB flag ON-OFF (No results).
  • Tried different file types (png, tga 32, tga 16).
  • Tried different texture settings (Default, UI Icon).
  • Assign Texture/Material directly trough the own imagewidget Interface.
  • Assign Material/Image trough a “BRUSH” Asset.
  • Assign Material Instance Dynamic (that’s what I’ll really need).
  • As you see, I’ve inserted the Texture also on a “standard” Material and applied on the Mesh it works without problems.
  • On the widget window it display without problems.
  • Looks like “ONLY” the UMG drawbuffer is being desaturated/whitetint.

How to correct this? Some engine.ini flag or bug? :frowning:

Thank You.

Widgets were in really “Disabled”.
Weird, the checkboxes doesn’t displayed this.

Anyway, I’m assuring now that ONConstruct everything get enabled.



I’m confused by your statement about the checkboxes not showing it. Your canvases “Is Enabled” property is unchecked. Which causes it and all children to become disabled.


This was on the beggining from my UMG Adventures lol.
I got confuse with thinking “Is Enabled” should be override by “SelfHitTestInvisible”, paying too much attention on Tooltips. LOL