UMG buttons disappear on android

Soooo, I have a main menu with UMG buttons. And one of them seems to disappear after a couple of seconds. It is still clickable and the text in the button does not disappear.

Now the weird stuff is, if I delete the button and create a new one. this button will stop having the problem, but another button will get the same problem… If I recreate that button again, another button will get the problem etc. It does not seem to be an issue with the button itself. But I have no clue at all what could cause this. I also tried to delete all text in the buttons and see what happens then. But then all the buttons are rendered for a couple of seconds and then they disappear… I do not see any weird settings or anything that could cause this I think…

Things I tried:

  • Deleting all other umg stuff in the umg scene, and deleting all code from this umg blueprint.
  • Deleting and recreating the buttons.
  • Deleting all text from the buttons ( which caused all buttons to get the problem)

Anybody that had an issue with this and was able to find the problem?
Thanks in advance!

EDIT: forgot to say, playing in editor or new window works fine, problem is only on android (maybe also ios, cant test it now)