Download

Ultimate Mobile Kit for iOS & Android - Firebase

Thanks to your help, Analytics works well now.
As for the Authentication though, signing in anonymously works but ‘Firebase Link with Credential’(google) doesn’t.
Attached are my blueprint setup and Firebase sign-in method settings.

Is this another one of those things not supported in the old engine?
Or are there any other steps I should take?

Hi,

are Universal Mobile Ads and Ultimate Mobile Kit plugins compatible on their respective last version? I am getting this error when trying to package for Android:


ATHelper: Packaging (Android (ASTC)): Dependency resolved to an incompatible version: Dependency(fromArtifactVersion=ArtifactVersion(groupId=com.google.android.gms, artifactId=play-services-measurement-sdk-api, version=16.0.4), toArtifact=Artifact(groupId=com.google.android.gms, artifactId=play-services-measurement-base), toArtifactVersionString=[16.0.5])
UATHelper: Packaging (Android (ASTC)): :app:preReleaseBuild FAILED
UATHelper: Packaging (Android (ASTC)): FAILURE: Build failed with an exception.
UATHelper: Packaging (Android (ASTC)): * What went wrong:
UATHelper: Packaging (Android (ASTC)): In project 'app' a resolved Google Play services library dependency depends on another at an exact version (e.g. "[16.0.
UATHelper: Packaging (Android (ASTC)): 5]", but isn't being resolved to that version. Behavior exhibited by the library will be unknown.
UATHelper: Packaging (Android (ASTC)): Dependency failing: com.google.android.gms:play-services-measurement-sdk-api:16.0.4 -> com.google.android.gms:play-servi
UATHelper: Packaging (Android (ASTC)): ces-measurement-base@[16.0.5], but play-services-measurement-base version was 16.3.0.
UATHelper: Packaging (Android (ASTC)): The following dependencies are project dependencies that are direct or have transitive dependencies that lead to the art
UATHelper: Packaging (Android (ASTC)): ifact with the issue.
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.android.gms:play-services-ads@17.1.2
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.firebase:firebase-analytics@16.3.0
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.android.gms:play-services-ads@16.0.0
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.firebase:firebase-core@16.0.7
UATHelper: Packaging (Android (ASTC)): For extended debugging info execute Gradle from the command line with ./gradlew --info :app:assembleDebug to see the dep
UATHelper: Packaging (Android (ASTC)): endency paths to the artifact. This error message came from the google-services Gradle plugin, report issues at https://
UATHelper: Packaging (Android (ASTC)): [github.com/google/play-services-plugins](http://github.com/google/play-services-plugins) and disable by adding "googleServices { disableVersionCheck = false }" to your b
UATHelper: Packaging (Android (ASTC)): uild.gradle file.
UATHelper: Packaging (Android (ASTC)): * Try:
UATHelper: Packaging (Android (ASTC)): Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
UATHelper: Packaging (Android (ASTC)): * Get more help at [https://help.gradle.org](https://help.gradle.org/)
UATHelper: Packaging (Android (ASTC)): BUILD FAILED in 9s

Unfortunately, this is not correct way to Link Credential with Google.
It should be like this:

However, Google recently changed Google Login (because of Google+ closure) and it has been implemented in Ultimate Mobile Kit 1.10.3 for UE 4.21. 4.18 is deprecated (not supported even by Epic Games) so it may not be working… What’s more we are technically not able to upload update for 4.18 because Epic has marked this release as very old and updating has been blocked… Again, we highly recommend to switch to newer engine version. If you can’t, we could discuss custom development request about rewriting the newest plugin for 4.18. If you are interested please contact us: support [at] gamednastudio.com

Hello,

What versions of Universal Mobile Ads and Ultimate Mobile Kit do you have?

​​​​​​​Thank you for your patience.

Hello,

Please update Universal Mobile Ads to 2.8.3 version: https://forums.unrealengine.com/unreal-engine/marketplace/65633-universal-mobile-ads-for-ios-android?p=1590858#post1590858

It should help :smiley:

Thank you for your patience.

Hi,
I ended up switching my project to 4.21.

After I set up the nodes exactly like you showed me, I could successfully sign in with Google but when I try to sign in with Google Play or link to Google Play, it always returns invalid credential.

I specified web application client ID and client secret to the Play Games authentication setting in my Firebase Console, following the official Firebase instruction.
Is there anything else needed to be done?

Please contact us on Discord: https://gamednastudio.com/discord and we will schedule TeamViewer session to help you directly on your computer :slight_smile:

Could a link to the download location for these files be added to the docs? Even in context I have no idea where they’re meant to be downloaded from. I eventually worked it out but it took a liberal application of googline.

Please login to your Firebase Console (https://console.firebase.google.com/), choose your app, and then click “Project Settings” icon. This is near “Project Overview” link. Then move down to “Your apps” section and there you will see “Download the latest config file”.

Yep that’s what you need to add to the docs.

Will do! Thanks for the suggestion :slight_smile:

I’m stuck on setup. I’ve put everything together according to the setup guide but Firebase isn’t registering my events.

Does this run on desktop for debugging, or only mobile? I’m calling the initialization method but I only ever get a failure on the desktop. I get nothing returned on mobile, neither failure nor success:

  1. Firebase is mobile-only so Ultimate Mobile Kit is also mobile-only. The only exception is Firebase Realtime Database which is available for all platforms: https://forums.unrealengine.com/unre…forms-firebase
  2. Have you installed SDKs using gameDNA installer?
  3. Is your plugin installed in the engine or project directory? This is a bug in the engine with including SDKs if Third-Party plugins are placed in the engine directory. So if you have installed it in the engine, please move plugin from [ENGINE_FOLDER]/Engine/Plugins/Marketplace/UltimateMobileKit to [PROJECT_FOLDER]/Plugins/UltimateMobileKit and try again.

Please let me know if it helped you. If not, could you please attach logs from your device?

Thank you for your patience.

  1. Gotcha
  2. Yes I have
  3. Project directory. On Mac it failed to build in the Engine directory anyway. :slight_smile:

I’ve gotten it running the initialization on the device now but it’s failing. How would you debug it? I’m a little wary of the fact that the setup was way too easy.

Edit: actually the gamedna installer is in the plugins directory. I’ll move the UMK plugin and try again! Thanks!

Edit again: yup that fixed it! That might also be worth noting in the docs about the Engine plugins folder. I know the setup says to use the project folder but it should say why.

I’m glad it works now for you! :smiley: We will include your suggestions into next iteration of docs :slight_smile:

Many thanks, for your wonderful support guys. A decent plugin worth spending money on!

Ultimate Mobile Kit 1.10.7 released!

We’ve just released big Ultimate Mobile Kit update for UE 4.21.
You can download it from GitHub repository on releases tab or your Sellfy dashboard (for Sellfy customers). Update also was submitted for UE4 Marketplace but it needs to wait for approval.

CHANGELOG:

  • Fixed retrieving Auth Code for Google Play Games Sign In on Android.

If you haven’t owned it yet, you can buy now on Sellfy or UE4 Marketplace.

I’m getting a crash on the latest version on iOS. Initially it’s OK but it feels like if I call two Firebase Analytics Log Event at once it crashes.

I’d give more info but I don’t seem to be able to set a provisioning profile for an iOS build in XCode, so I can’t run it with the debugger. If anyone knows how to get past that I’d appreciate advice on how to get it done. Isn’t Firebase meant to log crashes?

Also, are there any guides on how to actually use the data being collected in the Firebase console? I have data events appearing but not the actual data.

Hello Antidamage,

Please contact us on Discord (https://gamednastudio.com/discord) in order to schedule TeamViewer session and we will assist you with configuration of Ultimate Mobile Kit directly on your computer :smiley:

Hello, I’m stuck trying to implement on UE4.21 on Win10 with just analytics checked off and just trying to get it to work on IOS. I’m setting it up on a project that is mixed C++ and blueprint and requires remote build on a mac. Here’s my process so far: Downloaded from the Epic store which put the plugin in the Engine directory, set up GameDNA installer, installer failed because path too long, then moved my whole engine folder to c:\UE4_21, then success with gamedna installer. Installed the plist file with gamedna installer and looking at DefaultEngine.ini it looks happy as its showing all of the plist data ported in to the config. It builds in installs fine on the device. No action on analytics though. When I launch to device and then download the log, I see this error:

[2019.03.22-07.07.51:653] 0]LogUltimateMobileKit: Ultimate Mobile Kit CreateSubsystem!
[2019.03.22-07.07.51:654] 0]LogUltimateMobileKit: Warning: Ultimate Mobile Kit API failed to initialize!

Looks like it fails to initialize the core API.
I have tried reinstalling the sdk with GameDNA installer, then I moved the plugin to the project folder (which I should have done initially and would be a nice thing to add to the documentation startup, since moving UE4 engine from its installation folder to the drive root is not good for updates or installing other marketplace content), then tried reinstalling gamedna SDK and then going to the remote build machine and wiping out the build folder for the project and rebuilding it.

I guess I would look for anything that I’m obviously doing wrong here and also if there is any way to get it to spit out more detail on the log. I’ve tried using the debugger on the mac and it doesn’t provide any additional information.