Download

Ultimate Mobile Kit for iOS & Android - Firebase

Thanks for the quick response.
Step 1 and 2 were already done.
I tried moving the plugin to the project folder and now packaging fails.
Here’s the log.

UATHelper: Packaging (Android (ETC2)): Performing 6 actions (18 in parallel)
UATHelper: Packaging (Android (ETC2)): [1/6] clang++.exe Module.UltimateMobileKit.cpp [armv7-es2]
UATHelper: Packaging (Android (ETC2)): [2/6] clang++.exe Module.UltimateMobileKit.gen.cpp [armv7-es2]
UATHelper: Packaging (Android (ETC2)): [3/6] clang++.exe PCH.UELinkerFixups.h [armv7-es2]
UATHelper: Packaging (Android (ETC2)): [4/6] clang++.exe UELinkerFixups.cpp [armv7-es2]
UATHelper: Packaging (Android (ETC2)): [5/6] arm-linux-androideabi-ar.exe UE4-UltimateMobileKit-Android-Shipping-armv7-es2.a
UATHelper: Packaging (Android (ETC2)): D:/NVPACK/android-ndk-r15c oolchains/arm-linux-androideabi-4.9\prebuilt/windows-x86_64\bin/arm-linux-androideabi-ar.exe: creating D:/Unreal Projects/UnnamedProject(442)/Plugins/UltimateMobileKit/Binaries/Android/UE4-UltimateMobileKit-Android-Shipping-armv7-es2.a
UATHelper: Packaging (Android (ETC2)): [6/6] clang++.exe UnnamedProject-Android-Shipping-armv7-es2.so
UATHelper: Packaging (Android (ETC2)): D:\Unreal Projects\UnnamedProject(442)\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\Invites/FirebaseInvites.cpp:42: error: undefined reference to ‘firebase::invites::Terminate()’
UATHelper: Packaging (Android (ETC2)): D:\Unreal Projects\UnnamedProject(442)\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\Invites/FirebaseInvites.cpp:42: error: undefined reference to ‘firebase::invites::Terminate()’
UATHelper: Packaging (Android (ETC2)): D:\Unreal Projects\UnnamedProject(442)\Plugins\UltimateMobileKit\Source\UltimateMobileKit\Private\Invites/InvitesInitialize.cpp:27: error: undefined reference to ‘firebase::invites::Initialize(firebase::App const&)’
UATHelper: Packaging (Android (ETC2)): clang++.exe: error: linker command failed with exit code 1 (use -v to see invocation)
UATHelper: Packaging (Android (ETC2)): ERROR: UBT ERROR: Failed to produce item: D:\Unreal Projects\UnnamedProject(442)\Binaries\Android\UnnamedProject-Android-Shipping-armv7-es2.so
UATHelper: Packaging (Android (ETC2)): Total build time: 130.92 seconds (Local executor: 0.00 seconds)
UATHelper: Packaging (Android (ETC2)): Took 131.266053s to run UnrealBuildTool.exe, ExitCode=5
UATHelper: Packaging (Android (ETC2)): ERROR: Command failed (Result:5): D:\Program Files\Epic Games\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe UnnamedProject Android Shipping -Project=“D:\Unreal Projects\UnnamedProject(442)\UnnamedProject.uproject” “D:\Unreal Projects\UnnamedProject(442)\UnnamedProject.uproject” -NoUBTMakefiles -remoteini=“D:\Unre
al Projects\UnnamedProject(442)” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: ‘UnrealBuildTool-2019.03.02-07.01.00.txt’
UATHelper: Packaging (Android (ETC2)): (see C:\Users\Jakdu\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Program+Files+Epic+Games+UE_4.18\UAT_Log.txt for full exception trace)
UATHelper: Packaging (Android (ETC2)): AutomationTool exiting with ExitCode=5 (5)
UATHelper: Packaging (Android (ETC2)): BUILD FAILED
PackagingResults: Error: Unknown Error

Hello,

I see you use very outdated 4.18 version of UE4. This is almost 1.5 years old. In this version Firebase Invities doesn’t work. You can turn this off or migrate to the newer engine version what is highly recommended because of new features and many bugfixes.

My team’s using 4.18 for a reason, so although new features and less bugs sound great, migrating is not an option for us.

Anyway, it works!
After disabling Invites, the packaging was successful, and now both google play service and firebase analytics are successfully initiated.
I never thought it could be solved this easily.

Thanks a lot for your help!

EDIT : Actually, one more thing.
In the application, it says the analytics is initiated but there’s nothing on the Firebase console.
It’s only showing default events like screen_view or session_start. There’s no custom event.
Is there anything else I should do other than using “Log Event” node?

Events in Firebase Analytics Console shows up within 24 hours so you need to wait. You can also see live events in StreamView on Firebase Dashboard or DebugView following instructions on Firebase Documentation: Debugging Events  |  Firebase

Thanks to your help, Analytics works well now.
As for the Authentication though, signing in anonymously works but ‘Firebase Link with Credential’(google) doesn’t.
Attached are my blueprint setup and Firebase sign-in method settings.

Is this another one of those things not supported in the old engine?
Or are there any other steps I should take?

Hi,

are Universal Mobile Ads and Ultimate Mobile Kit plugins compatible on their respective last version? I am getting this error when trying to package for Android:


ATHelper: Packaging (Android (ASTC)): Dependency resolved to an incompatible version: Dependency(fromArtifactVersion=ArtifactVersion(groupId=com.google.android.gms, artifactId=play-services-measurement-sdk-api, version=16.0.4), toArtifact=Artifact(groupId=com.google.android.gms, artifactId=play-services-measurement-base), toArtifactVersionString=[16.0.5])
UATHelper: Packaging (Android (ASTC)): :app:preReleaseBuild FAILED
UATHelper: Packaging (Android (ASTC)): FAILURE: Build failed with an exception.
UATHelper: Packaging (Android (ASTC)): * What went wrong:
UATHelper: Packaging (Android (ASTC)): In project 'app' a resolved Google Play services library dependency depends on another at an exact version (e.g. "[16.0.
UATHelper: Packaging (Android (ASTC)): 5]", but isn't being resolved to that version. Behavior exhibited by the library will be unknown.
UATHelper: Packaging (Android (ASTC)): Dependency failing: com.google.android.gms:play-services-measurement-sdk-api:16.0.4 -> com.google.android.gms:play-servi
UATHelper: Packaging (Android (ASTC)): ces-measurement-base@[16.0.5], but play-services-measurement-base version was 16.3.0.
UATHelper: Packaging (Android (ASTC)): The following dependencies are project dependencies that are direct or have transitive dependencies that lead to the art
UATHelper: Packaging (Android (ASTC)): ifact with the issue.
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.android.gms:play-services-ads@17.1.2
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.firebase:firebase-analytics@16.3.0
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.android.gms:play-services-ads@16.0.0
UATHelper: Packaging (Android (ASTC)): -- Project 'app' depends onto com.google.firebase:firebase-core@16.0.7
UATHelper: Packaging (Android (ASTC)): For extended debugging info execute Gradle from the command line with ./gradlew --info :app:assembleDebug to see the dep
UATHelper: Packaging (Android (ASTC)): endency paths to the artifact. This error message came from the google-services Gradle plugin, report issues at https://
UATHelper: Packaging (Android (ASTC)): [github.com/google/play-services-plugins](http://github.com/google/play-services-plugins) and disable by adding "googleServices { disableVersionCheck = false }" to your b
UATHelper: Packaging (Android (ASTC)): uild.gradle file.
UATHelper: Packaging (Android (ASTC)): * Try:
UATHelper: Packaging (Android (ASTC)): Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
UATHelper: Packaging (Android (ASTC)): * Get more help at [https://help.gradle.org](https://help.gradle.org/)
UATHelper: Packaging (Android (ASTC)): BUILD FAILED in 9s

Unfortunately, this is not correct way to Link Credential with Google.
It should be like this:

However, Google recently changed Google Login (because of Google+ closure) and it has been implemented in Ultimate Mobile Kit 1.10.3 for UE 4.21. 4.18 is deprecated (not supported even by Epic Games) so it may not be working… What’s more we are technically not able to upload update for 4.18 because Epic has marked this release as very old and updating has been blocked… Again, we highly recommend to switch to newer engine version. If you can’t, we could discuss custom development request about rewriting the newest plugin for 4.18. If you are interested please contact us: support [at] gamednastudio.com

Hello,

What versions of Universal Mobile Ads and Ultimate Mobile Kit do you have?

​​​​​​​Thank you for your patience.

Hello,

Please update Universal Mobile Ads to 2.8.3 version: https://forums.unrealengine.com/unreal-engine/marketplace/65633-universal-mobile-ads-for-ios-android?p=1590858#post1590858

It should help :smiley:

Thank you for your patience.

Hi,
I ended up switching my project to 4.21.

After I set up the nodes exactly like you showed me, I could successfully sign in with Google but when I try to sign in with Google Play or link to Google Play, it always returns invalid credential.

I specified web application client ID and client secret to the Play Games authentication setting in my Firebase Console, following the official Firebase instruction.
Is there anything else needed to be done?

Please contact us on Discord: https://gamednastudio.com/discord and we will schedule TeamViewer session to help you directly on your computer :slight_smile:

Could a link to the download location for these files be added to the docs? Even in context I have no idea where they’re meant to be downloaded from. I eventually worked it out but it took a liberal application of googline.

Please login to your Firebase Console (https://console.firebase.google.com/), choose your app, and then click “Project Settings” icon. This is near “Project Overview” link. Then move down to “Your apps” section and there you will see “Download the latest config file”.

Yep that’s what you need to add to the docs.

Will do! Thanks for the suggestion :slight_smile:

I’m stuck on setup. I’ve put everything together according to the setup guide but Firebase isn’t registering my events.

Does this run on desktop for debugging, or only mobile? I’m calling the initialization method but I only ever get a failure on the desktop. I get nothing returned on mobile, neither failure nor success:

  1. Firebase is mobile-only so Ultimate Mobile Kit is also mobile-only. The only exception is Firebase Realtime Database which is available for all platforms: https://forums.unrealengine.com/unre…forms-firebase
  2. Have you installed SDKs using gameDNA installer?
  3. Is your plugin installed in the engine or project directory? This is a bug in the engine with including SDKs if Third-Party plugins are placed in the engine directory. So if you have installed it in the engine, please move plugin from [ENGINE_FOLDER]/Engine/Plugins/Marketplace/UltimateMobileKit to [PROJECT_FOLDER]/Plugins/UltimateMobileKit and try again.

Please let me know if it helped you. If not, could you please attach logs from your device?

Thank you for your patience.

  1. Gotcha
  2. Yes I have
  3. Project directory. On Mac it failed to build in the Engine directory anyway. :slight_smile:

I’ve gotten it running the initialization on the device now but it’s failing. How would you debug it? I’m a little wary of the fact that the setup was way too easy.

Edit: actually the gamedna installer is in the plugins directory. I’ll move the UMK plugin and try again! Thanks!

Edit again: yup that fixed it! That might also be worth noting in the docs about the Engine plugins folder. I know the setup says to use the project folder but it should say why.

I’m glad it works now for you! :smiley: We will include your suggestions into next iteration of docs :slight_smile:

Many thanks, for your wonderful support guys. A decent plugin worth spending money on!