UE4 Wont Package

EveryTime I package My game It fails. The whole list is right here
https://docs.google.com/document/d/1Su_wZ7txzdTlw0k6IlG_hJeM2vnZ_93TIFiqCk4J-qg/edit?usp=sharing
Thanks.
link text

Hello,

  • Are you able to package a clean project successfully?
  • What platform are you attempting to package for?

I am packaging for Android, and Yes I can package an empty project.

Could you attempt to package again and grab the log from your Project’s Saved->Logs folder after the packaging attempt fails? I am having trouble getting the link you provided to load.

Thank you.

Ok Thanks, In the meantime when It started crashing is when I tried to implement ads and Achievements. Do I have to do something else with it like in this video? - YouTube
If so How come I didn’t see anything about this on the documentation? Thanks. :slight_smile:

Also I added the Log In the Original question as link text

I have never done those things in that video and I can package my project for android in 4.11

I can’t make sense of most of it, and I don’t have the personal time to sort through it all, but I noticed that it kept referencing “error: class, interface, or enum expected” and the automation tool exited with “exit code:5” .

Here’s something I grabbed:

[2016.04.28-22.26.36:616][322]MainFrameActions: Packaging (Android (All)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:5): F:\NonSteamGames\new folder\Epic Games\4.11\Engine\Binaries\DotNET\UnrealBuildTool.exe MobileGame1 Android Development -Project=“F:\Other stuff\Unreal Engine 4\Unreal Engine Projects\MobileGame1 4.11\MobileGame1.uproject” “F:\Other stuff\Unreal Engine 4\Unreal Engine Projects\MobileGame1 4.11\MobileGame1.uproject” -remoteini=“F:\Other stuff\Unreal Engine 4\Unreal Engine Projects\MobileGame1 4.11” -noxge -NoHotReloadFromIDE -ignorejunk. See logfile for details: ‘UnrealBuildTool-2016.04.28-17.24.15.txt’

Might be related, I honestly have no clue…

Are you using a code or blueprint project?

If it’s code, is the project compiling successfully in Visual Studio?

blueprint.

Hello,

Have a look at this Answerhub post: ERROR: cmd.exe failed with args /c "C:/NVPACK/apache-ant-1.8.2/bin/ant.bat" debug - Debugging, Optimization, & Profiling - Unreal Engine Forums

The accepted answer should contain the solution to your packaging issues based on the errors I’m seeing in your logs.

Have a great day

I’m Pretty Sure I have it all in there. I have this picture. Alos sorrry for late reply I’ve been busy.

Thank you for your response.

Have a look at these posts as well and see if any of these solutions work for you:

https://answers.unrealengine.com/questions/270725/ (The comment by Samantha Sutton, not the accepted answer on this one)

Let me know if any of these help.

Thank you for your reply’s (I REALLY appreciate your help) Although Unfortunately neither of the directed links seems to have helped. I am currently uninstalling and reinstalling the NVIDIA and NVPACK files again to see if I did something wrong in the first place(But I highly doubt it since I packaged the game many times and for some reason it started not working only after I tried to implement ads). In the meantime maybe some more suggestions?

Hi.

Are you still able to package a clean project for android successfully? if so, no need to reinstall NVPACK then.
I think your problem is the way you created your project.

did you ever code for your project in c++? can those code be built and compiled successfully?

is not there any Error in your Blueprint? I can see one in the logs you sent "Error Blueprint Runtime Error: Accessed None trying to read property K2Node_DynamicCast_As2DSide_Scroller_Character2 from function: ‘ExecuteUbergraph_MainMenu’ from node: Save Game in graph: EventGraph in object: MainMenu"

these are also other problems you have from your logs

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.10:959][246]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: The system cannot find the path specified.

[2016.04.28-22.26.11:292][247]MainFrameActions: Packaging (Android (All)): UnrealBuildTool: Building Java with SDK API level 'android-21'

I think the following is the main problem "UnrealBuildTool Exception: ERROR: cmd.exe failed with args /c “F:/NVPACK/apache-ant-1.8.2/bin/ant.bat” debug"

google for this text "UE4 ERROR:NVPACK/apache-ant-1.8.2/bin/ant.bat"

You will find different Kinds of answers. see which one can help you.

if you have any new log send it

your other error "Unable to load module ‘AndroidAdvertising’ because the file ‘F:/NonSteamGames/new folder/Epic Games/4.11/Engine/Binaries/Win64/’ was not found."

you have got lots of warnings and errors @_@

if I were you I would reinstall windows first and I would re download all UE4 stuffs again in a situation like this. :smiley: (and I would lose at least 5 years of my brain’s life time) after doing those things.

Another suggestion I can offer you is to go through your logs and try to resolve the error messages that you see in there one by one. There seem to be quite a few error messages, as stated by saeedc in their answer below, and you’ll need to resolve these before you can package your project successfully.

Let me know if reinstalling makes a difference.

I Figured it out FINALLY. After searching other questions for a long time I found a guy said to manually save every asset. so i highlighted as many assets then right clicked save then I opened the next folder highlighted the assets right click ETC. So for some reason that fixed it. Can a staff member please tell me why that fixed it? Is that a bug and if so are you guys gonna fix? Thank you.