Download

UE4 is messing up my textures

I just downloaded the Kenney Platformer package on the UE Marketplace. All of the textures are .uasset files.

When I look at the images in my project, they are all blobby as you can see in the picture attached called ContentBrowser. If you compare the cactus from my picture of Content Browser to the cactus in the SpriteSheet picture (cactus is at top right), then its obvious there’s a difference in the two. Why am I getting blobby images?

This has happened to me in a seperate project when I was bringing in .PNG’s for textures. The solution was to use .PSD files instead of .PNG’s. These are .uasset files though. Something seems fishy. It leads me to believe there is a feature somewhere that I need to change or something. Why would UE not be able to use .PNG’s? Or .uassets? I mean, .PNG is one of the more popular image formats used.

Here’s a picture of my texture editor window when I double click on the cactus texture from CB. Is there something in it’s settings that I haven’t handled correctly?

a5c0b85fffb669775c730e98d08dd2705c9a416f.png

Thats normal behavior when you import it as a png. You can set the Texture Group Mode to UI and it will go away, however it will show the full res of the texture.

These are .uasset’s not .PNG’s. Also, changing the texture group to UI didn’t change anything.

Did I do it wrong? I selected UI from Texture Group’s dropdown menu and clicked the save button.

Here’s what it looks like now…

All assets are UAssets, what I meant is that the raw(imported) format is PNG. Try setting the compression settings from Default to TC_UserInterface2D

Note: when they are placed in the world or in a material they wont appear that way. You should be able to go to the “View” button (In the texture viewer) and see the transparency that its supposed to have as well.