UE4 crashes when opening a map

So, I spent all day yesterday working on a project and now when I come to work on it today every one of the incrementally saved maps crashes the Editor when I try and open them!
The maps all compiled, worked and played fine whilst I was working on them with no errors or anything…

Here’s the callstack generated by the Crash Reporter (I have submitted it as well).
crashLog.txt

As you can probably imagine, this is extremely frustrating and I’m really loath to spend time working on the project again until I know if it’s anything I’m doing that’s causing the problem…

Does anyone have any ideas?

Thanks,
teed

Hi teed,

Does this only occur on the one project or has this occurred on a blank project with no additional content or with one of the Epic sample projects?

Hi Adam,
It only seems to happen on this one project…
I’ve been working on it for a few days and had the occasional crash, but thanks to incremental saves hadn’t lost too much work.
However, the other day I opened a map and then spent all day working on it saving new maps as I was working. Then when I came back to it, every incremental save (other than the initial starting map) crashes when I open the map. The project itself will open fine, but the crash occurs when I try and open any of the maps.

The Loading Map dialogue gets to 98%, then hangs for a moment and then the editor crashes.
Sometimes I get a full crash Log, other times, I just get this:

!Id:906a204edc99adfd8dd9942065c03e28

No minidump found for this crash.

Hi teed,

Do you know if you added any content before the crash started occurring? If you know what content you added, try removing that content, then load up the editor to see if it works. If it does, start slowly adding content back in until it crashes again. This will help to determine if it is a specific asset that is causing the problem. Thank you!

I didn’t add any custom content before any of the crashes… Everything in the level so far is just brushes and the assets (mostly from the Shapes folder) that come with UE4 as I’m just blocking things out and prototyping systems.
I’ll try and find a working map and attempt to recreate what I was doing…

So, it would appear that there is no rhyme or reason to the crashes!
Today, I went right back to a very early map that was opening and got as far as incremental save 16 (saving, restarting the editor and re-opening every time) before a crash occurred. So, I open v15 which crashed as well! having opened fine previously. I ended up having to back to v6 to get one that opened.
I then tried to recreate the steps back to get to where I was before the crash happened and was able to get up to v22 before a crash happened (which is beyond the point of the previous crash). I have just had to go back to v18 and rebuilt back up to v22 which has just opened fine.

As you can probably imagine, this is quite frustrating as the crashes seem unpredictable and the only way that appears to be safe in terms of working is to save after every little change (ie. move an actor’s location) just in case…

Can you suggest anything?

Hi teed,

If you have a test map in your project that is producing this crash and you would feel comfortable sharing, we would be more than happy to have a look to see if we can discover what is going on. We only need the bare minimum that causes the crash to occur, anything else is unnecessary to send along.

Hi Adam,
Thanks for offering to take a look at the map.

I wasn’t sure whether you just wanted the map or whether you needed the entire project, so as the map is the smaller of the two, I’ve gone for that.

I’ve created a .zip file which contains the map itself and some assets which I created using elements from the projects provided within UE4. I wasn’t sure what assets were actually in the map so I’ve provided you all of the ‘custom’ stuff… There’s a readme doc which lists the assets and their location within the Content folder of the project.

Link to file

Hopefully, I’ve given you everything you need… If not, let me know.

Thanks,
Teed

Hi teed, can you send the project folder with it’s contents in the .zip. Thus far I haven’t been able to reproduce anything. Thank you!

Hi Adam,
That’s odd and very frustrating!
I’ve double-checked that level (GAT2_Cave_14_07_01_008.umap) on 2 different PCs and it crashes on both!
I’ve uploaded the entire project folder here.
You’ll see that there are a number of more recent map files in there… I have managed to move forward in the project although I haven’t changed anything in terms of content or approach so these contain the same assets and systems that are in the maps that crash.

Hi teed,

I have been able to reproduce this on the list of maps below. I will pass this along to be assessed. Everything after the 07_01 set seems to work just fine, however:

GAT2_cave_14_06_27_002

GAT2_cave_14_06_29_001

GAT2_cave_14_06_30_018

GAT2_cave_14_07_01_002

GAT2_cave_14_07_01_003

GAT2_cave_14_07_01_004

GAT2_cave_14_07_01_005

GAT2_cave_14_07_01_006

GAT2_cave_14_07_01_007

GAT2_cave_14_07_01_008

Why has this thread been marked as ‘Resolved’? A reason for the crashing hasn’t been provided and as the crashing has continued to occur with more recent versions I would appreciate knowing why it is happening so I can avoid it.

Hey, has there been any changes to the engine on your side? The reason I’m asking is that some objects have been saved in those maps that had no right to be saved (they are marked as Transient, and would normally be rejected when saving).
The crash occurs because something is trying to re-create these objects and since they’re in the loading queue it simply finds those, however since they haven’t finished loading yet, the editor crashes.

Hi Robert, No, I haven’t made any changes to the engine, so I’m not sure why this would be happening… Is there any way for me to manually delete these objects?

teed

This looks very similar to my issues, certainly the crash message is the same:

Try opening up all your BP assets (any user structures?) before opening the level to see if that solves your opening the map issue as with mine I can open a level if I get the assets open. However the order you open them is critical and basically a result of trial and error (very frustrating)

It could also be random as if its going to work or not :confused:

Hi xrouter,
Thanks for your comment.
There are no user structrues in any of my BPs. In fact, they’re all relatively simple assets that are primarily based off assets that are provided within some of the example projects supplied by Epic (eg. the ContentExamples project).
I’ve tried opening all of the BP assets (in various configurations) before opening the map and have not been able to successfully open the map.

Hi teed,

If you could modify UInterpData::CreateDefaultFilters() code to look like this:

	UInterpFilter* FilterAll = FindObjectFast<UInterpFilter>(this, TEXT("FilterAll"), true);
	if (!FilterAll)
	{
		FilterAll = NewNamedObject<UInterpFilter>(this, TEXT("FilterAll"), RF_Transient | RF_TextExportTransient);
	}
	FilterAll->SetFlags(RF_Transient);
	FilterAll->Caption = TEXT("All");
	DefaultFilters.Add(FilterAll);

(note the FindObjectFast before it attempts to create the filter and SetFlags to make sure RF_Transient is set)

Then that should basically fix your problem (depending on the load order you may need to add this to all of the other filters in that function).

Having said that, it’s a hack and only a workaround to get you going but since I was unable to repro this locally (and haven’t heard from any of our teams about this problem) and I couldn’t find a culprit in code, for now I’m assuming it must have been a bug in one of the older versions.

Hi Robert,
Thanks for coming back with a suggestion, but I’ve tried it (although I may not have done it correctly), and the editor still crashes when I try and open a map.

Just to confirm:
I opened the InterpData.h file, and then navigated through the code to the UInterpData class, then within this to the void CreateDefaultFilters() function.
This function was empty, and so I copied and pasted the code that you provided into the function.

Was that correct?
Did I need to build / recompile the code?
Sorry, I’m not that experienced with the source code side of the engine as I’ve been using Blueprints up to now.

I’ve attached the error log that was generated when I attempted to open a map.

Thanks again,
teedlink text