Ue4 constantly crashing when editting a blueprint and pressing compile

It’s saying there are nodes that need to be refreshed. Have you tried that? You right-click on one of the nodes in the graph and choose “Refresh Nodes”. There’s no major errors in that log though. If it’s crashing then you should post the crash log as well.

If refreshing the nodes doesn’t help… Your problem sounds familiar but I’m coding at such a rapid pace that it’s all a blur. Are you using 4.18.2? If not, you might want to see if upgrading fixes the problem. Your assets may be corrupted so upgrading your latest project might not fix anything. But if it doesn’t, you can use the last version that works and upgrade that. I’m pretty sure I remember having an issue like this.

This should help you find the crash log:

This problem started yesterday morning when one of my AI controlled character blueprints started to crash whenever I made some changes to it and hit compile. This was things like adding variables and editing the components attached to it. For some reason this fixed itself, perhaps because I recreated the blueprint from scratch. This has now began to happen on my main character blueprint and it would seem silly to try and recreate this if it would spread to my other blueprints again. If have left the latest crash report attachedlink text. Does anyone know what this is and if they do, how to fix it?

I am using UE4.18.2. I refreshed the nodes but it didn’t change the result. Where would I find the crash log?

I went back to using a backup from 2 days ago and remade everything I changed since then and it works fine. This works as a solution but it doesn’t really explain what is really going on.

Ok, I found it. link text

I can’t imagine why it would be, but is the CharacterBP asset file read only? It’s in Content/CharacterBP/Pawns/.

Unfortunately there is little debug info in there. I don’t know why UE4 isn’t shipped with debug symbols but it isn’t so your stack trace is bereft of meaningful information. I do see that it starts to warn about “FindLookAtRotation” in CharacterBP. You could try bypassing that. See if it fixes the issue. It’s a long shot but you never know without debug info.

For some reason the blueprint has fixed itself. I tried to recreate the problem but I couldn’t seem to do it. I’m going to mark this as resolved but if it comes back, I’ll reopen it. Thanks for your help.