UE4 build won't run on SHIELD Tablet/Android

I’ve downloaded the source from GitHub for 4.5.1. I’ve done a rebuild, modifying the BaseEngine.ini file such that the bBuildForES31 flag is set to true (I’ve tried leaving bBuildForES2 set to true as well, and also tried setting to false).

When I launch to the SHIELD Tablet, or package and deploy (using both “Shipping” and “Develop” builds of UE4 Game target for Android), the build will launch, show a black screen, then exit back to the Android tablet “desktop”. UE4 remains running if you look at the tasks, and you can switch back, however upon doing so it dumps you back again in the “desktop” of the tablet.

What’s the best way to debug why this is not running. Incidentally, when I deploy using the pre-built binaries from the unrealengine.com, it will run, albeit at insanely slow speeds (2fps).

In such cases try checking logcat which will show you log output from your device, potentially giving you hint whats wrong

Hi, any luck making ES3.2 work on shield? Im having same problem.