UE4.7 Preview 5 Cant compile my project from 4.7 Preview 4 version

When i today update engine version from 4 to 5 preview my project crash. Before update work very well but after update i cant compile. The probable cause is havent source folder in project. Earlier clone version project havent source folder too.
When i compile in VS i have that log error

LogInit:Display: Running engine for game: Desire
LogModuleManager:Warning: Found module file …/…/…/…/…/…/Users/Tomasz/Desktop/UnrealProjects/Desire/Binaries/Win64/UE4Editor-Desire.dll (API version 2408319), but it was incompatible with the current engine API version (2425717). This is likely a stale module that must be recompiled.
LogInit:Warning: Incompatible or missing module: UE4Editor-Desire.dll
Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe Desire Development Win64 -project=“C:/Users/Tomasz/Desktop/UnrealProjects/Desire/Desire.uproject” -rocket -editorrecompile -progress
ERROR: Couldn’t find target rules file for target ‘Desire’ in rules assembly ‘Desire_EditorRecompileModuleRules, Version=, Culture=neutral, PublicKeyToken=null’.
Location: C:\Users\Tomasz\Desktop\UnrealProjects\Desire\Intermediate\Build\BuildRules\Desire_EditorRecompileModuleRules.dll

Please help me, its importent for me(1 month work time)

Thanks guys.

Hey gegagoflow-

Something you can try would be to delete the Binaries folder from your project (or simply move to another location). Then right click on the .uproject and select the option for “Generate Visual Studio project files”. This will recreate your .sln file for the project. Using the new solution file, build the project again to recreate the binaries folder which should create an up-to-date .dll



When i delete Binaries folder from project when i try “Generate Visual Studio project files” i have error “This project does not have any source code. You need add c++ source files t this project from editor before you can generete project files.”

When i compile project in VS i have error try reproduce source code manually.

Its probable to do something or i must create project anew?

The Source folder is where the source files for the project are located. Without this folder the project has not way to properly associate/process the code appropriately. Unfortunately the only solution in this case would be to recreate the project.

I know this is a bit late to the show for the answer to this, but I came across a similar bug, so maybe this will help someone in the future.
Project (re)started in 4.7, just upgraded to 4.14 and got the same “This project does not have any source code. You need add c++ source files t this project from editor before you can generate project files.” error. I’d previously converted the project from BP to BP/C++, but never added a C++ class, which was causing my packaging to fail due to a flag that was C++ and unbuilt (not previously a problem), and was unable to generate VS files.

The fix was to add a blank C++ class, which caused linkage to VS 2015 and I was then able to generate VS files and package my build. I hope this helps other folks in the future.