UE4.10 Skeletal Mesh / Animation Issue not seen in UE4.9

We’ve been using LightWave to animate skeletal meshes. In Unreal 4.9, the exported FBX files from LightWave translated perfectly. However in 4.10, both the skeletal meshes and the animations are riddled with problems. The skeletal meshes are coming in rotated in random rotations even when they’re all facing the same direction in LightWave. The animations are importing but when we preview the animation or apply it to the mesh, the pieces of the mesh come apart as if we’re viewing an “assembly” style animation from a CAD program.

The exact same FBX imports into Unreal 4.9 perfectly with no issues. Bringing the FBX into 4.10 and using the exact same import setting yields unusable and unfixable problems.

If we import the FBX into Maya, the animation comes in perfect. All bones are present and all vertex weighting is correct.

Currently we are having to import our skeletal meshes into Unreal 4.9 and then migrate them to our 4.10 projects. But obviously this is problematic as it makes updating the animation in our 4.10 project a nightmare.

I have tested this with multiple FBX files. All of them work fine in 4.9. All of them work fine in Maya 2015. None of them work in 4.10. It’s clear that something changed in the FBX import process in 4.10 but I don’t know what.

Has anyone experienced this problem or can anyone at Unreal shed light on what might have changed and then how we might fix the problem?

Thanks in advance.

I’ve similar issues here. Some FBX (from Maya ver.FBX 2014/2015) that imported correctly in 4.9 crash 4.10. The ones that do import seem to lose the rotation animation on the root joint.

I have to do more FBX import tests to narrow down what works and what currently doesn’t in 4.10.

You’re right. It’s definitely losing rotation on the root joint. Even if I go into the animation asset after import and enable animation on the root joint, it doesn’t fix it.

I’ve got a vehicle animated along a path. The root bone is controlling both the position and primary orientation. However it’s coming into 4.10 with no orientation info. Just position.

I’m seeing the same exact problem. Rig/Animations imported from Maya 2015 in FBX format. No root animation, all other joins animate correctly. When re-importing the FBX back into Maya it works fine, and it even animates correctly in Unity.

I have not been able to reproduce this exporting a simple stick man animation created in Maya 2015 (using the 2014 FBX exporter) and was thinking it may have to do with how you have your animations rigged in Maya and/or Lightwave (Still a bug.) Can any of you send a test FBX with a description of how it was created and rigged including which version of the FBX exporter you are using? If you do not wish to share a link to the file here, you can send it to me in a private message on our .

This will greatly help expedite the bug reporting process. -Thanks,


I just tested this again using 4.10.4 and am still getting issues. It’s better than it was before, but it’s still not right.

I’ve created a new scene for you to test this with from a model I found online. Rigged and animated the model in LightWave 2015. Exported the scene using the FBX 2014 Binary format. Imported the FBX into Maya. Looks just like it did in LightWave. Imported the FBX into UE4.9. Looks just like it did in LightWave. Imported the FBX into 4.10.4. The animation comes in, but the animation is not right. It’s as if one or more bones are not getting their anim data.

I’ve uploaded everything to Dropbox. When you extract the archive, you’ll get two UE4 projects. One is for 4.9. The other is for 4.10.4. Inside each is a copy of the original FBX skeletal mesh and animation. All you have to do is load each project and compare. Then, load in the FBX Anim into Maya. (I’m using Maya 2015.) You’ll see that the 4.9 scene looks just like the anim in Maya. But the 4.10 scene does not.


If you have any questions, please don’t hesitate to let me know. I’m stuck using 4.9 for all rigged animation until this is fixed, so I’m hoping this gets resolved soon!

Unless I’m missing something, the way to compare this “apples to apples” is to take the same FBX file exported from Maya and see if it imports correctly to UE4.9 and incorrectly for U4.10. That said, I tried to repro the issue following these steps:

  1. Created a new Maya 2015 file using the robot arm A) skeletal mesh and B) animation exported from UE4.9
  2. Exported skeletal mesh and animation from Maya to an FBX
  3. Imported FBX into a new blank UE4.9 Blueprint Project
  4. Compared UE4.9 Project to Maya file/animation RESULT: match
  5. Imported the same FBX into a new blank UE 4.10 Blueprint Project
  6. Compared UE4.10 Project to Maya file/animation RESULT: match

Conclusion: Unable to reproduce the issue when FBX is exported from Maya 2015 using the 2014 version of the FBX exporter. However, there may be a conflict between UE 4.10 and LightWave’s FBX exporter. I am not familiar with Lightbox, but in Maya there are different, updated FBX exporters. If possible, please update Lightbox FBX exporter and see if this resolves the issue.

Also, another user who was having an issue with joint rotations in UE 4.10 reported they were no longer having an issue in UE 4.11 preview 8. Please try exporting to this version to see if it resolves the issue.

Finally, as a workaround, another user has verified that importing to UE4.9 then using that uasset works in UE4.10.

I respectfully disagree. The only thing that testing the FBX pipeline from Maya does is determine that UE4 is tolerant of Maya FBX files. It does not address the core issue, which is that the FBX files coming from LightWave work with previous versions of UE4, but then break starting in 4.10. I have not updated LightWave. There has been no change in the FBX exporter. The only thing that changed was UE4 going from 4.9 to 4.10. And therefore, the problem lies with something inside UE4.

To test this problem, you should take the FBX file that I sent and try loading it into UE 4.9 and 4.10. If you get different results, then the problem is undoubtedly UE4, not the source program.

LightWave, Modo, Blender and Cinema 4D are all capable of exporting FBX files. The test here shouldn’t be whether Maya’s FBX files work with UE4. It should be whether UE4 reads FBX files properly.

If Maya can read a LightWave FBX and interpret its animation correctly, so should UE4. Again, the problem here is UE4’s interpretation of the FBX, and that’s clearly illustrated by the fact that Maya interprets the FBX animation correctly whereas UE4.10 does not.

I have been able to import animations into 4.9 and then port them to 4.10. And I can say that this does work. I have also heard from other users that 4.11 Preview fixes the problem with joint rotations. However we don’t switch projects mid-development cycle. And there are things in 4.10 that we would like to use.

I sincerely appreciate you taking the time to look into this. If 4.11 fixes this issue, then it is a moot point. I will cross my fingers and give that a try once we are through with our current projects.

I was expecting one FBX file generated from Lightwave but this is what I received (two project folders):

If the original FBX (not already imported) is among those project directories, let me know it’s location or you can send me just an FBX generated from Lightbox and I will retest.

My apologies. I mentioned this when I posted the project files but in re-reading, I can see that it wasn’t entirely clear. The original FBX files (skeletal mesh and skeletal mesh + animation) are in the Content / Geometry / Meshes folder for each project. These are the FBX files you should use for testing, both by bringing them into UE4 and by bringing them into Maya. You’ll note that Maya and UE4.9 interpret the animation the same way. But UE4.10 does not.

Importing the RobotArm_Anim.fbx resulted in the animation functioning correctly for UE4.9 and UE4.11p8 while broken in UE4.10. This issue appears resolved for UE4.11. Please test and let me know if you do not get the same results.

Very cool. I’ll give 4.11 a shot and will let you know what I come up with.

Oh, and please forgive the lack of manners. Thanks so much for all the help!

Thanks for the sentiment but it is not necessary. If you think we’ve got it wrong, are misunderstanding the issue, or missing something, we encourage you to point out our mistake. Our goal is to identify and correct as many bugs as possible.

Let me know when you’ve had a chance to test this in UE4.11p8. The model you provided worked as it did in 4.9 for me but I thought you may have other, more complicated samples to test with.

Greatly appreciate that. I downloaded UE4.11p8 today and as you noted, everything seems to be working again. I have a more complex rig that I’ve been using and will test this more extensively once I’m wrapped up with my current project. But for now, I think it’s safe to say that this issue is resolved in 4.11. Thanks again!