Download

UE4.10 game menu issues

Hi to everyone.
Please forgive me If there is a similar thread like this but i have tried to search with no results.
I am making a game menu but I have two issues.

  1. i can’t set resolution game. I have two buttons and i have associated in the graph editor the command r.setres 1280x720 to one and the same command with 1920x1080 resolution to the other one.
    After compyling and saving I launch the menu in stand alone mode but the buttons doesn’t work.
  2. I need to clean the menu screen everytime i click on a button so If I click on resolution button on the left side of game menu, two buttons with two avaiable resolutions appears on the right side. Then If i click on another button, on the left side, the two buttons with avaiable resolution disappears and a new window (or image or any other content type) appears in the same side.
    Someone who can help me?

Does this work if you type it into the console?

HTH

Thank you for reply. Where exactly should I type hth? After r.setres command?

The HTH stands for Hope That Helps.
Does the r.setres if you do that manually ?

Ohhh ok ok sorry but I was at work and i didn’t read carefully. I typed the command in the execute console command like into a videotutorial that i am following.
You can see this tutorial at this link https://youtu.be/SPzjL-j4Aas at min38
I made exactly as shown in the videotutorial. And tiping the command in the execute console command this not work. I have checked the command syntax and it’s ok. I don’t know where I am wrong. Next time i will update some screens.

Okay, That is strange.

I have used that exact command in PIE and a development build/package and it works.
Perhaps there is a bug or something went wrong with your project.

Have you tried using the command in a different project to see if it is some kind of conflict or something with your project?

HTH

Hi. i tried to use the same command into another project and it works. So i deleted all blueprint and i redone everithing and now it works. I didn’t know what I was wrong. So thank you for your help.

That’s unfortunate that you had to do that to get it to work, I had something similar where I got stereo rendering for no aparent reason.

You’re welcome