Download

UE 5 not showing .uasset files from UE4

Hi all…
I’m sorry if this has been asked before, but I didn’t see anything while searching.

I started a project in UE4. I imported a bunch of FBX files into that UE4 project, creating blueprints, creating materials etc.

  • First I tried to open the UE4 project in UE5 allowing it to convert. Got tons of failed to import errors.
  • Second, tried to migrate from UE4 to into a new UE5 project . Migrate didn’t have any errors, but when I opened up the new UE5 project, I noted that while the folder structure was in tact, none of the assets were showing up in UE5 content browser even though the files are there in Explorer.
  • Tried a 3rd option. New UE5 project, in explorer simply drag all the UE4 assets into the new UE5 project… Still won’t display…

Actually, there are a few things that DID show up, but it was ONLY Textures. Oddly, those textures just like all the other files are .uasst files.

Anyone have this problem and overcome it?

I think UE4.27 has a lot of problems. so the best thing to do if it is a small project is just to restart in UE5. If not, you can wait for other solutions.

Wanted to be sure I fully understood. You’re saying that migrating from UE4.27 has issues?

Starting over is possible I suppose. Still a LOT of work. I have a LOT of models that I would have to rebuild all the custom collisions for.

Is this a common known issue? One other thing to note is that all the folders show up in UE5 just fine.

4.27 is fine and one of the most stable builds the issue is 5EA is not compatible with 4.27 files as 4.27 was released after 5EA. IF you want to export to EA you need to use 4.26 like the docs say. If your using git to get the latest UE5 release from 5.0 or Main branch you it will work. other then that you need to wait till 5.0 release before migrating from 4.27 to 5

1 Like

Hi volkiller…

Thanks for the clarification!

100% correct.

I really would love to see the newest ue5 main branch in the launcher, simply to stop this kind of forum topics. They popup x times a day.

I also have problems with opening UE5. Its so annoying. I have installed it twice. Does anyone has solutions.

I think you’ll need to wait until the next release to be able to use 4.27. It may load from the 5.0/5.1 source builds but I’ve had problems getting either of those to work properly. 4.27 will not load in the current EA build though.