Download

UE 4.9 crashes immediately on GearVR

I finally installed 4.9 today. I copied one of my fairly simple projects that worked in 4.8 and converted it to 4.9, got no build errors, and tried it on the device, but it goes straight to Oculus Home. So I started a new project natively in 4.9, basing it off of the C++ First Person template I always use, enabling Gear VR plugins and disabling other VR plug-ins, setting up the Gear VR packaging info, etc. Normally it works straight out of the box for me but it’s juddery unless I strip it down, but I didn’t bother since I just want to see it run at any frame rate. Same deal, immediate crash to Oculus Home. Then I saw the comment in the Release Notes about using the 0.6 Oculus Mobile SDK, so I went and downloaded the latest (0.6.2.0) and installed the newest NVPACK files that it came with.

I can’t think of what else I might need to change, but it’s not working. What am I missing? I haven’t come across other posts about this so I feel like it must be something silly. When I migrated from 4.7 to 4.8 everything just worked with no changes for me.

What would be the best way for me to debug this myself?

Note 4, Snapdragon, Lollipop on Verizon (5.0.1 - yes I checked for OTA updates about 20 times today!).

That officially supported Gear VR template would sure be handy about now!

Thanks guys!

-Dave

hey Dave,

I also had problems migrating my project from 4.7/4.8 to 4.9 - I found a few components caused it to crash.

You’re best bet is to try something really simple - totally blank project with a floating sphere with a unlit color material to make sure you’re not missing something - for example placing your ossig file in the correct 4.9 engine folder.

After I got that working then I tried stripping my project down to find out what was causing it to crash - in my case it was a scene reflection component that was showing instanced meshes - still to work out the exact cause of the crash but after removing this it runs without crashing. next task for me when I’ve time to find out exactly what in that component causes the crash so I can re-implement it :slight_smile:

It appears to me the MSAA feature or new 0.6 Oculus Mobile SDK in 4.9 does not work with some other UE4 features and causes an abrupt crash :frowning:

I’ve just run into this issue again. I found the OSIG was the biggest gotcha. Make sure you have in the right place, search for OSIG here: https://docs.unrealengine.com/latest/INT/Platforms/GearVR/Prerequisites/index.html

It may not be your issue but even though I knew about it and used for other projects I still somehow missed it when setting up a fresh engine install.

With the release of Unreal Engine 4.9 TDAP is no longer used to package Android based projects. An entirely new program called Android Works is now used to package your Android projects which you can find in Engine / Extras / Android folder. Let us know if this helps you out at all or not.

Turns out I hadn’t moved the OSIG – I could have sworn I didn’t have to when I moved to 4.8, but I probably just forgot about it. Anyway 2 of my simple demos work fine now (YAY!!!), though one still immediately crashes out to Oculus Home. Will have to poke around a little this weekend and try to figure it out.

The release notes seem to say MSAA is enabled by default on the Gear, but my higher-res textures are still shimmering like crazy, and I’ve got prominent aliasing on my geometry edges too. Any ideas?

Thanks again for the help, as always!

-Dave

Edit: also, I did use Android Works.

Edit #2: Ok I’m not entirely sure what’s up now. I did a bunch of rebuilding things repeatedly and tried a number of times and finally the demo that was crashing out seems to be working. It might even have less aliasing (it doesn’t have any high-res textures though so they weren’t as bad to begin with). I did remove a “stat fps” that I had in there as well, not sure if that’s related. It’s hard to tell but I think it’s not as jaggy as before. So maybe I just have some files in an old crufty state after doing the migrate or something… Will have to keep digging to see if I can replicate this on the other demos.

I had a similar issue.
Resolved it after reading Aussieburger’s post.

A scene capture camera with render to texture material (I.e a mirror) was causing an immediate crash.

created an answerhub ticket for this bug: Scene Capture 2D crashing Android apps in UE4.9 - UE4 AnswerHub

Anyone know another way to generate a simple minimap in the meantime?