[UE 4.7.6, Windows 8.1 64Bit] Crash On Launch

EDITED: Incorrect Build Version stated by mistake.

Branch: Binary

Build Version: 4.7.6 - ??? (Unable to view About Unreal Editor due to the nature of the issue)

Detailed Description of the Issue: Upon a fresh/first install of UE4.7.1, the Editor worked fine for the first 24-36 hours off on and off, launched and exited use. Upon the following morning, I closed and saved a 2D C++ Template Project that I had studied and then stripped down to basic actors, and tried to open the First Person C++ Template to study some of it’s assets and utilize them in the former. Upon this, the Editor crashed to desktop, generating a crash report (No longer findable, unfortunately). Afterwards, I attempted to re-launch the Editor through Epic Games Launcher as per normal, which it immediately crashed at ~45% Initialization, this has since been consistent with all attempts to launch the Editor.

Steps to Reproduce:

  1. Unknown number of uncertain steps.
  2. Launch Unreal Engine Editor 4.7.1 via Epic Games Launcher
  3. Crash occurs during loading of the Engine/Editor itself.

Basic System Specs:
http://puu.sh/hXJ2z/bab589aee2.png

Crash Log Details:

Will try to provide more information as requested.

Hey Itsapainfulworld,

Thank you for reporting this issue to us however, I do have a few questions for you. Are you able to launch 4.8.0 Preview 3 without any problem? Have you tried verifying 4.7.6 to see if that fixes the issue you’ve ran into? Have you tried opening the editor by going through the following folders (\Epic Games\4.8\Engine\Binaries\Win64)? Make sure that you try to open the ‘UE4Editor.exe’ when you attempt this method.

Looking forward to hearing back from you, thanks!

  1. I was not aware of a 4.8 Preview being available.

  2. Again, I have not been aware of a “Verify” option. Am I safe to assume it is similar to Steam’s “Verify Integrity Of Game Cache” function available for games with missing or corrupt files, and if so, how would I access it?

  3. I had not thought of that prior. Unfortunately, as of ~5 minutes ago, it produces the same result as starting it from the Epic Games Launcher. Gist is here in case part of the crash log is different. UE4.7.6 Crash Log #2 · GitHub

Overall, I’ve not been reading up on how to troubleshoot issues with the Editor itself, instead reading up on and trying to practice functionality and features of the Editor via the documentation pages.

Come 2:00 AM, US Central Standard Time, I will consider either a clean install or locating and opting into the 4.8 Preview if I am allowed to, as both are in the range of ~10GB downloads, and my current ISP is less than generous with my data allowance before that time and after 8:00 AM (And even then it’s pretty limited, meaning I can only feasibly reinstall so many times a month without paying up extra money that I might not have).

EDIT: I find the lack of an uninstaller AND the fact that it does not show up under Programs And Features to be…very worrying.

Hey,

If you wish to see which versions of the engine are available, click on the drop-down arrow that’s underneath ‘Unreal Engine’. It’s in the upper left corner of the launcher and the button beside the drop-down should say “Launch Unreal Engine x.x.x”.

If you want to verify your version of the engine, you simply would go to Library and click on the drop-down button that’s beside Launch. Once you’ve done that, you should see verify.

Verifying the engine basically checks the installation to make sure the files aren’t corrupt, and verifies all files were included into the installation.

If you wish to uninstall and reinstall the engine, you can go into your Programs and Features section under the Control Panel and scroll down to Unreal Engine. That’ll uninstall the engine from your computer.

By the way, what type of graphics card do you have? That’s not included in the screenshot you provided with your computer specs.

Looking forward to hearing back from you, thanks!

  1. I’m only finding the 4.7.6 version available, so again, I’m assuming that previews are either for privileged users, or something I have to opt into.

  2. This appears to have worked. It’s good to know the option to verify files with the launcher is available, for future cases.

  3. “Unreal Engine” does not appear under Programs And Features, nor does “Epic Games Launcher” or any noticeably similar entries.

  4. I’d have to do some checking, I do know it is an AMD, with the graphics drivers being fairly outdated (Catalyst 14.4) due to all later versions being wholly incompatible with a large, fairly popular online service that I peruse moderately. This has not appeared to cause issues with anything else I use, and AMD is reportedly working on betas of new versions that address the issue.

I suppose this marks the issue as resolved, for now. Thank you for your help Samantha.

Hello,

Did you go to the Library and look under the ‘+ Add Versions’ section to add any version of the engine that you do not currently have? Also, do you know if your graphics card is DirectX 11 or higher in capability? Also, if you go into the Epic Games Launcher under the Library tab, you can click on the drop-down option and click ‘remove’. This would remove that version of the engine, if you believe it’s corrupted.

Let me know if you have any further questions. Have a wonderful day and good luck! :slight_smile: