UE 4.24.1 and 4.24.3 crashing on startup after recent Windows 10 Professional automatic update

So when booting my PC for the first time today it was “finishing up” an automatic update, when I went to open Unreal Engine 2.24.1 it crashed immidiatly after displaying the splash/loading window for like less than a second.

So at first, I tried just restarting my system, no luck, then updating to 4.24.3 and verifying the files from within the Epic launcher, no luck, reinstalling 4.24.3, still no luck as well as visiting my system settings recovery section, where I got greeted by that it havent saved any backups since before the automatic update.

4.23 still seems to work, however the project Im working on is on 4.24 and I would rather try and get 2.24 working again than downgrading my project

Here is a screenie of the crash report as well as a video on what it looks like when I attempt to start the program: UE4 4.24.3 - Album on Imgur

And here is my log file: https://pastebin.com/6vX1vJVh

And as far as Im aware, Microsoft doesn’t let you download older versions of Windows from there servers, so it seems Im stuck on this new broken update :l Everything else works fine, its just Unreal 4.24 that wont boot.

Bumping message

Still struggling with this, Im in touch with Unreals support but we still havent figured it out

Any help would be greatly appreciated

Updated pastebin’s (after installing the debugging symbols) :

Assertion failed: IsValid() [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Core - Pastebin.com (crash report)

Not using cached read wrapperStarted task graph with 5 named threads and 14 to - Pastebin.com (My log file)

Well, looking at the crash report it looks like an error check failed regarding two things bound to the same chord, right? Did you check for that in your config files?


No, I didnt know it was related to my config file at all. I dont know any C++ (nor any programming language for the matter)

But if I would make some guessing after reading myself up on this a bit, at line 849, it converts “something” (I guess its something below in the hierarchy thats not in the screenshot at all? ) from being an “operator” to a “const” (no idea what either of those are), then at line 850 it checks if the output/result of that is a valid “const”, and if it is it returns that “const” (at 851) and then continues on with the code below, meanwhile if its not a valid const it wont return and thereby the process stops aka the application goes unresponsive?

And then you’re saying that the “something” is something from the config then?

My config is supposedly unmodified, I’ve never changed anything inside of the editor preferences other than some keybindings, so could just deleting the config work as a solution (assuming that it will then auto generate?)?

Yesterday I tried building UE4 4.25 from the GitHub source and see if I could get that running, which it did! So Im up and running again now with this version (Which I’ve now converted my project version to). So this isnt very urgent no longer

Thanks for the reply btw :slight_smile:

Most informative comment/response I recieved anywhere so far, not even Epics own support pointed that out when I got in touch with them

Very similar to that Game crash when connecting to server - XR Development - Unreal Engine Forums