UE 4.15.1 crashes continually on launch Mac OS

Hi,
I have read in some post about theses crashes that I need a Metal supporting hardware.
My iMac is supposedly supporting metal …but I still cannot run UE 4.15.1 :frowning:

I have tried Verify, un-/reinstall but nothing seems to work.
I also installed “Visual Studio Code”

still crashes…

Here is my setup:

Model Name:	iMac
  Model Identifier:	iMac17,1
  Processor Name:	Intel Core i7
  Processor Speed:	4 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	8 MB
  Memory:	32 GB
  Boot ROM Version:	IM171.0105.B20
  SMC Version (system):	2.34f2

MD Radeon R9 M395X:

  Chipset Model:	AMD Radeon R9 M395X
  Type:	GPU
  Bus:	PCIe
  PCIe Lane Width:	x16
  VRAM (Total):	4096 MB
  Vendor:	ATI (0x1002)
  Device ID:	0x6920
  Revision ID:	0x0000
  ROM Revision:	113-C905AA-799
  EFI Driver Version:	01.00.799
  Metal:	Supported
  Displays:
iMac:
  Display Type:	Built-In Retina LCD
  Resolution:	5120 x 2880 Retina
  Pixel Depth:	30-Bit Color (ARGB2101010)
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Automatically Adjust Brightness:	Yes
  Connection Type:	DisplayPort

And the error log

LoginId:c036ccfa7f42a1b32a6fcf8b937b5318
EpicAccountId:e37eac6a5afc4192837fa15eca7f5be1

 SEGV_MAPERR at 0x978ff0d0

_platform_memmove$VARIANT$Haswell Address = 0x7fff8c0c0efc (filename not found) [in libsystem_platform.dylib]
void FGenericPlatformString::LogBogusChars(char const*, int) Address = 0x109f5dd5e (filename not found) [in UE4Editor-Core.dylib]
operator<<(FArchive&, FString&) Address = 0x109f3549a (filename not found) [in UE4Editor-Core.dylib]
FMemoryDerivedDataBackend::LoadCache(wchar_t const*) Address = 0x121648f06 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseBootCache(wchar_t const*, wchar_t const*, FString&) Address = 0x121658006 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseNode(wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x1216545ed (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseHierarchicalCache(wchar_t const*, wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x121658454 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseNode(wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x1216546b5 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseAsyncPut(wchar_t const*, wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x121658b73 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseNode(wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x121654936 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseKeyLength(wchar_t const*, wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x121658944 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::ParseNode(wchar_t const*, FString const&, wchar_t const*, TMap >&) Address = 0x121654894 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataBackendGraph::FDerivedDataBackendGraph() Address = 0x1216533b2 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataCache::FDerivedDataCache() Address = 0x121666afb (filename not found) [in UE4Editor-DerivedDataCache.dylib]
InternalSingleton() Address = 0x12164679c (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataCacheModule::GetDDC() Address = 0x12167d069 (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FDerivedDataCacheModule::StartupModule() Address = 0x12167cfdf (filename not found) [in UE4Editor-DerivedDataCache.dylib]
FModuleManager::LoadModuleWithFailureReason(FName, EModuleLoadResult&, bool) Address = 0x10a23f8be (filename not found) [in UE4Editor-Core.dylib]
FModuleManager::LoadModule(FName, bool) Address = 0x10a23e5c6 (filename not found) [in UE4Editor-Core.dylib]
IDerivedDataCacheModule* FModuleManager::LoadModulePtr(FName) Address = 0x10a1a5f74 (filename not found) [in UE4Editor-Core.dylib]
GetDerivedDataCache() Address = 0x10a1a5ef0 (filename not found) [in UE4Editor-Core.dylib]
GetDerivedDataCacheRef() Address = 0x10a1a5fe8 (filename not found) [in UE4Editor-Core.dylib]
GetGlobalShaderMap(EShaderPlatform, bool) Address = 0x10c461a56 (filename not found) [in UE4Editor-Engine.dylib]
FEngineLoop::PreInit(wchar_t const*) Address = 0x109e504c7 (filename not found) [in UE4Editor]
GuardedMain(wchar_t const*) Address = 0x109e628d1 (filename not found) [in UE4Editor]
-[UE4AppDelegate runGameThread:] Address = 0x109e7053c (filename not found) [in UE4Editor]
-[FCocoaGameThread main] Address = 0x10a09b366 (filename not found) [in UE4Editor-Core.dylib]
Unknown() Address = 0x7fff7816dbcd (filename not found) [in Foundation]
_pthread_body Address = 0x7fff8c0c79af (filename not found) [in libsystem_pthread.dylib]
_pthread_body Address = 0x7fff8c0c78fb (filename not found) [in libsystem_pthread.dylib]
thread_start Address = 0x7fff8c0c7101 (filename not found) [in libsystem_pthread.dylib]

Hey Wrksboink-

Are you using the editor from the Launcher or did you build the engine from GitHub source? The error log information matches another crash that we have seen but have been unable to reproduce (Unreal Engine Issues and Bug Tracker (UE-24658)) . Please provide any information about your process that leads to the crash for you to help us investigate the issue.

Hi Doug, this for looking into this. :slight_smile:

I have downloaded the launcher. And installed the binary.
The installation did not showing particular error and seemed to be ok.

However when I started the engine up the first time nothing seemed to happen
so I started it again only to have 2 instances running at the same time…
the engine never came up but crashed at 35% so maybe that messed something up I thought.

But removing and installing again did not help. so I guessed it was not that.

After reporting the problem I tried installing 4.14.3 and that installed just fine. ??

Regards

Looking at the error messages, there appear to be files missing from the installation. Can you try removing/deleting the DerivedDataCache and Intermediate folder from the 4.15 install location, then run Verify again. If you are still unable to launch the engine please follow the steps in this link (A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums) under the “Getting Debug Logs” section to provide the actual launcher logs. Also, if you navigate to the 4.15 install folder, are you able to launch the engine directly from Engine/Binaries/Mac/UE4Editor.app?

Hey Wrksboink-

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Cheers

Doug Wilson