Download

UCX_ custom collisions are being modified by Unreal

I’ve created an fbx file with two meshes inside:

Teapot and UCX_Teapot being UCX_Teapot a sphere, I know its weird, but it was for testing.

Unfortunatly when I import the .fbx even if I uncheck “generate collisions” my collision is a reduced version of UCX_Teapot instead being the high res mesh.

Is there any chance to avoid this?

Thanks in advance

When you use a sphere, you need to use the proper prefix, USP, instead of UCX. Take a look at this page and scroll down to collision for more information:

Also double check that on the import tab that you have “auto generate collision” disabled:

https://docs.unrealengine.com/latest/images/Engine/Content/Types/StaticMeshes/HowTo/Importing/ImportOptionsDefault.jpg

I said a sphere but I mean any custom mesh gets simplified.

About “auto generate collision” I asume it doesn’t matter according to https://forums.unrealengine.com/showthread.php?120380-UCX-and-UE-4-13&highlight=UCX_

Thank you anyway!

That is wrong as far I know, Auto Generate Collision does exactly what it say, it creates automatically collision boxes for you, and if its unchecked, it will look for collision meshes in your file and if found, import them as collision. Have a look at the tutorial here:

Would like to get some clarification from someone more experienced or from Epic.

Yes, in the post I spotted a Epic guy says the oposite :S