Download

Trying to dynamically control size of the particles via Blueprint at runtime

I have created a simple particle system from the default particle system: They are identical except one has type data as GPU sprites. Here is the UI I am controlling it with :

https://forums.unrealengine.com/filedata/fetch?filedataid=132261&type=thumb

Two actors with each with a particle systems is created, I assign the two different template of particle system to it. The Particle settings are also attached. The GPU particles are not updating based on the vector parameter size distribution, any ideas of why its missing it ? Or is there a different way we should be calling a dynamic update on GPU particles ? Please advise.

I have tried to refer to similar question asked in Answer hub : https://answers.unrealengine.com/questions/338548/changing-size-dynamicly-gpu-particles.html
However the information doesn’t seem to have helped me resolved this issue. I have tried a different combinations for the max and const values as discussed in the answer.

Zero Control :

https://forums.unrealengine.com/filedata/fetch?filedataid=132260&type=thumb

Max out Control :

https://forums.unrealengine.com/filedata/fetch?filedataid=132258&type=thumb