Transparency in raytraced reflections


I am using RayTracing in ue 4.25. I have a barbershop scene with many mirrors on the sides. And in the raytraced reflections in the mirrors, I cannot see glass. It shows up as black where the glass is in all my mirrors. Mirrors just have a basic metallic, 0 roughness material.

I would love if someone can help and please don’t say it is not supported :D:D.

It’s going to require more than a material with merely metallic and roughness, I think. It could be as simple as changing the number of reflection bounces to 3 or more (possibly 2, but not likely). That’s inside the PPV. If there isn’t a PPV, put one around the barbershop scene, go to Reflections and select Ray Tracing in the dropdown, then to Ray Tracing Reflections > Number of Bounces and set the value. Enable refraction too, with 2 checkboxes to enable. Set quality to 100 too.

Otherwise, it may require a different, bit more complex material setup. Could you post a screenshot of the scene area? It would help in getting suggestions and a fix for it.

I have enabled raytraced reflections and refraction 3 bounces or 2 doesn’t change anything.

Are the mirrors using planar reflections? or are they simply the material you made?

What is Blend Mode, Shading Model, and Material Domain for the mirrors? Are they set to be visible in ray tracing, AND in reflections?

Mirrors are a completely standard material they have unique textures from painter and I just have no normal on them. I can see the opposing mirrors correctly. The only thing I cant see is that glass door.

You can see here that the mirrors show up in the mirror but the glass door shows up without the translucency. It keeps the small bit of roughness variation and the metallic value I have in the glass material on the door.

I see now. The earlier screenshot showed mostly the door in the mirrors, but there’s one which appears to be another mirror (in the closest mirror on the left, there’s a black frame). So, I thought it was not showing the other mirrors per mirror, but didn’t stop to see how it’s mostly the door that is not reflected. What are the other settings of the RT Reflections? Perhaps it’s because there’s no normal on them that the door is not reflected?