Transferred from another PC - Epic Games Launcher has stopped working

Hello all.
I live in an area with an abysmal internet speed (30-100kbps) and I can’t really download anything. I want to get into unreal so 2 days ago I downloaded and installed UE4 on another pc with a great download speed (2.5mbps) and copied it over to my pc (same path - D:/Unreal). When I started the launcher, it discovered Unreal engine, it said installing, verifying and it tries to download a 90mb file. Without fail, every time at 5% downloaded, the launcher crashes and the download stops.
There is absolutely no way I can download more than a few mb on my net, so redownloading and reinstalling is out of the question. My computer is pretty good, with all drivers updated. I have an i5 4690k, 16gb ram, a ton of HDD space and a GTX960 4GB graphics card.
Can I patchwork solve this crash or do I have to forget about Unreal?

I would like to update this thread as solved. Since I had transferred the installation from another computer, I didn’t have any shortcuts, and thought the Launcher troubleshooting didn’t really apply to me. However, I did make a new shortcut of the D:\Unreal\Epic Games\Launcher\Engine\Binaries\Win64\EpicGamesLauncher.exe file on my desktop, and used the hook -http=wininet and it worked like a charm!

There might be regedit files and things that are installed onto the PC and that’s why it crashes possibly.

You could try downloading the version of the engine on GitHub with the fast internet speed PC and then compile it on your PC at home. I think you need Visual Studio installed to do this though.

Only other option might be to bring your PC to the place you are getting faster speeds and try again.

You don’t need the launcher to run UE4.

Go here:

And run:

Thanks both for your suggestions. As I said the problem was solved by making a new shortcut and adding that http command, which leads me to believe (if my assumption that it does something to the network is correct) that the launcher couldn’t handle my **** speed or something and was “clogged”.