Download

Totally screwed on lighting... I'm either going to be WAY too bright, or WAY too dark.

I really don’t know what I’m going to do. If I use my normal lighting, then my game looks great on two of my four machines, but barely any visible light on my other two machines. If I disable the sg.PostProcessQuality (set it to 0 or 1) to keep the darkness across the board and work with that as a base to build acceptable lighting from, I have to add too many lights which drops the frame rate way down.

I can’t bake any lighting because everything is generated at runtime, and so there’s nothing to bake.

The lighting on my MSI laptop:
lighting-again.jpg

The lighting on my iMac:
95aa0c356f48862eb88d5b33f06aebaeeca80440.png

The harsh shadow is necessary as there’s a time limit for completion. The moon moves from one side of the map to the other, so the shadow acts as a visual reminder of how much time you have.

Any help or setting change ideas would be great. I’ve posted a few times on this and got no reply. I’m literally at the point of getting ready to upload, but I’m stopped by this ONE LAST PROBLEM!!!

Go to project settings and under render tab turn off exposure, it think that is what is messing you up. Long live marketing and their buzzword options.

Just turn off everything there you do not need. Most options are barely noticeable (or plain annoying) in games. Sadly Epic marketing did not learn from UT3 mistakes.

I got the same issue with exposure, it produces strange results where i expect more lighten level within some camera angles.

THANK YOU!!! This has been so FRUSTRATING for me. This appears to put everything on the low-light playing field, but now it’s just a matter of adjusting settings across the board, it seems. I’m reworking my lights right now, but once I’m done here, I’m going to package it and take it to the other computers for comparison. If the lighting checks out, hopefully I can have a distributable copy ready by the end of the weekend. :slight_smile: