Download

Top Faces Gray after importing into Unreal - Really simple mesh

I’ve made a simple model in Maya and I’m trying to import it into Unreal. I saved the file as fbx through Maya and then trying to import.

The mesh is UV mapped and Normal map applied. But I haven’t applied any texture yet. I’m trying to import into unreal to see if I’ve made any mistakes on the model before texturing.

This is how the model looks in Maya LT

I’m importing into Unreal with the following settings

And finally in the engine it looks like this.

I tried opening the normal map in UE and changed the green channel checkbox… Gray gets a little lighter and that’s it.

Can anyone tell me why this is happening?

Hi,

Was the screenshot taken after light baking? Looking at the shadows my assumption would be it was.

If so, try to import your mesh without checking “GenerateLighmapUVs” when importing. Note, that you have to make your own lightmap then, here is how you do it:
https://docs.unrealengine.com/latest/INT/Engine/Content/Types/StaticMeshes/LightmapUnwrapping/

If you want to test your model in dynamic lighting conditions, just set every light in the scene to “Moveable”, then your meshes should only cast dynamic shadows.

Yes. This was after rebuilding the lights. I did make my own light maps with lots of space in between each face but it didn’t make any difference. It’s still the same. I’ll post my light map UV layout in a while.

Try opening your mesh in the Editor and set your lightmap resolution to a higher value if you haven’t done that already (the default is 64x64). Also, check your Build Quality settings and make sure it is not on Preview.
I would also check the mesh how it looks in an environment with only dynamic lights to rule out lightmap issues.