Download

to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

Crashes repeatedly for me. I’m losing my marbles. 4.13 worked fine, 4.14 makes an nvidia quadro 1000m with 2gb ram die. I will post specs or crash reports if they’re pertinent but I am super bummed out right now.

Adding my experience to the pool of unlucky users.

Crashes as well on a R9 380. Drivers have been updated.
4.10 engine was not crashing
4.14 crashes randomly
No other games crashes.

And it looks like Epic already fixed it. Unreal Engine Issues and Bug Tracker (UE-37999)
Though, won’t be released until 4.15, not hotfix for 4.14 ?? :eek: :eek: :eek:

We have fixed one cause of the crash, but other causes still exist and are under investigation. The fix actually went into the 4.14.2 Hotfix, and our data is showing that we have reduced the frequency of the crashes (or rather the number of users who are experiencing them) by possibly up to about 40%. We will continue to work to identify the cause of the remaining crashes. Sharing your system specs and 100% repro steps (including assets that cause the crash) can help immensely. (please post your information to the UE4 Answerhub Bug Report section.)

Thanks

Hey Stephen,

I’ve posted my report here : Graphic driver Crash - AMD R9 380 - UE4 AnswerHub

It wasn’t easy to get though, most of the time the Editor would crash without generating a report.

Thanks

I think I might have found a workaround solution for now!!! In the content browser pane: click the little eye that says “View Options” and uncheck "Real-Time Thumbnails."

I spent several minutes rapidly rolling my mouse over mesh/materials preview windows, while in a blueprint, and it hasn’t crashed yet! Normally, it would have crashed in <5 seconds of doing that. Nothing has changed, in terms of my laptop. Before unchecking that option, even while in 4.14.3, it would still crash every time.

Wow! After uncheck "Real-Time Thunbnails, editor is working well.
Thanks IronicParadox.

Nice find IronicParadox turning off Real-Time Thumbnails has reduced the crashes i was having in 4.14.3 by a significant amount, i still get a crash when opening an instanced material shortly after compiling a parent but if i wait for the compile to complete it dose not crash.

Before finding the above workaround i had been testing the launch option -opengl4 which in my case stabilized 4.14.3 for what i use it for i did notice some material setups i had made did not function in this rendering mode.

Glad it helps! Yeah, I had been stuck using opengl as well and it’s compatibility/performance isn’t all that great. I spent a great deal of time trying to rule things out and it all honed in on the real-time thumbnails. I can’t even tell you how many hours I spent trying to figure it all out.

The only other thing that I’ve noticed is that it does cause a little bit of hard drive thrash on each thumbnail highlight. I’m probably going out on a limb here, because I don’t really know the inner workings of the editor or the graphics drivers, but maybe the graphics card expects information to be loaded and if the hard drive doesn’t load it in a specific amount of time, then it causes the graphics card to hang or be removed(my error is almost always gfx removed). Another possibility is that it’s getting stuck in some infinite loop; which sounds the most likely to me. I’m sure a dev could debunk these theories though.

I can definitely say that as the program gets ready to crash, gpu usage shoots up to 100%. You can even draw back the settings to the point that the card doesn’t even use 30% of the gpu, while playing in viewport, and it will still shoot up to 100% usage when the thumbnail crash happens. I will have to play around with it all some more and see because it doesn’t seem to be tied to the TDR settings either. I can set TDR to something higher and all it will do is make my computer sit there for that duration before it crashes the rest of the way out. You can try underclocking into oblivion and it doesn’t change anything either. Example: I can underclock to 1/5th of the gpu’s normal stats and it will crash every time.

I’m on 4.14.3 binary version. Currently, as soon as I open my master** animation blueprint** this crash occurs. My animation blueprint is quite complex and uses many nodes and I had ~6 tabs open. This crash didn’t occur in 4.12.5.

Is the new layout of the animation editor more rendering intensive?

[SPOILER]
Fatal error: [File:D:\Build++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:176]
UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225]
UE4Editor_D3D11RHI!FD3D11Viewport::PresentChecked() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:275]
UE4Editor_D3D11RHI!FD3D11Viewport::Present() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:458]
UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:562]
UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1347]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindow_RenderThread() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:486]
UE4Editor_SlateRHIRenderer!TGraphTask<FSlateRHIRenderer::DrawWindows_Private'::35’::EURCMacro_SlateDrawWindowsCommand>::ExecuteTask() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\async askgraphinterfaces.h:868]
UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async askgraph.cpp:932]
UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async askgraph.cpp:679]
UE4Editor_RenderCore!RenderingThreadMain() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:320]
UE4Editor_RenderCore!FRenderingThread::Run() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:454]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]
[/SPOILER]

Thank you IronicParadox, 4.14.3 was unusable until i turned off “real-time thumbnails”. Whether it still crashes from other issues . . . i hope not. But again thank you, had been very frustrating.

I switched to Forward Rendering and have since then no more crashes. I think the GBuffer got too big to handle for my graphic card when using the animation blueprint.

Hi all.

I’m glad that some of you are finding workarounds for this issue.

I want to update all of you that we are still looking into these crashes, and we have logged a new ticket for tracking them: Unreal Engine Issues and Bug Tracker (UE-42280)

Cheers

Turning off the Real-time Thumbnails seems to have helped here. I also disabled realtime view in the editor, show FPS and stats and the r.[something something] setting.

I just updated to 4.15.2 (from 4.15.1) and am now having this problem for the first time ever. I crash randomly within 5 minutes of running the game. I have a gtx1080 and have the latest drivers installed. Very frustrating that I can’t go back to 4.15.1 which worked great for me. (My performance is always significantly worse with sceneCaptures.)

I have the same problem.

same problem on NVidia drivers (382.05). Older drivers were not showing the crash. You can try reverting to a previous driver.

My UE 4.16.1 suddenly became very unstable and is constantly crashing with this issue :

Crash due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)
https://issues.unrealengine.com/issue/UE-42280

So after reading about this i’ve tried the following solutions:
-Remove 4.16 completely and reinstall. : FAIL
-Uncheck realtime thumbnails in content browser : FAIL
-Downgrade the nvidia display driver to legacy versions : FAIL
-Use MSI Afterburner to clock down the GPU : FAIL
-Run Engine with -dx12 : FAIL
-Change to use forward render : SUCCESS

So all attempts to fix this fails except removing the deferred render option.
But this is no solution, as i need the deferred render for my project.

So is this a pure driver issue? 4.14.3 works without any problems.
Is there a fix in sight? as per now 4.16 is broken for me :frowning:

Please please please please please please please fix this soon.
It makes UE4 entirely unusable and has halted my project.

Open skeletal mesh, animation, persona in general? Crash half the time.
Doing anything, especially in compiling big BP’s? Crash half the time
Open particle system editor? 100% crash.
Add scene reflection sphere? Crash.

The list goes on and on. I’ve been counting them and I’ve had over 100 crashes the last few weeks alone and some areas of the editor are entirely unreachable because they always crash.

I have tried ALL suggested workarounds, nothing works.

If I can help in any way - let me know. I’ve been sending crash logs the whole time.

Are you sure that you’ve correctly tried all of the work arounds? If you set it into forward rendering mode, you’d have to restart the editor because it will have to recompile every single shader in your game and usually takes forever and a day on that first relaunch; after you change to FR. I’m around 95% sure you won’t have any more crashes like that.

Though while I’m here, I may as well complain some more about getting these crashes left and right. Even though it crashes all the time, I still stay in deferred rendering because I need it for effects and things that aren’t supported in forward rendering. For me, it’s always the DXGI removed error and never the hung error. I’m not going to submit 30 error reports per day, so please don’t ask for anymore of them. A while back, I sifted through the source code to see the errors and if I recall correctly, it was being removed due to an unknown error, so it defaults to the “removed” error in those cases. I’d have to double check though.

My guess is that it has to be some kind of low level interfacing issue between the deferred rendering engine(mostly directx, but still crashes in opengl here and there), the directx/ogl api and the video card drivers. It started around 4.12 or 4.13 because before that, I had never once had a crash like that. I remember testing it out where I still had the previous engine version installed. I couldn’t get it to crash no matter how hard I tried and yet the later version would crash on demand; every time. Therefore, I’m almost positive that the problem lies with the unreal engine and I doubt that nvidia/amd drivers are to blame because those drivers were a variable that was held constant.

Just a quick question. Has anyone experienced this crash in a packaged build? I’ve been using the UE4 Editor (4.15.3) without any crashes, yet I’ve been getting more and more reports of the game crashing with this error report:

I’m just wondering if this crash is related to the editor only or if this also affects a packaged build?
I can run my game fine and it seems that the affected GPU cards correspond with my own reports.