Download

to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

Digging thru stuff I found another related crash. I opened BP_Sky_Sphere, clicked on Sky Sphere Mesh, and it crashed. I also use the QFE and run on GTX 550 Ti with 375.86 drivers.

The crash is not related to a particular asset, I manage to reproduce it very often with a standard third person project just created. You just have to play a bit with materials on the main char or open panels where there is a material or mesh preview. This bug is a real problem. Is there anyone who tested any previous versions of 4.14 which are ok? I cannot go to 4.13 as my assets are not compatible with it, but maybe an earlier version of 4.14 will do?

My laptop has an Intel 3000+Nvidia 540m (optimus) with Windows 10. The Intel drivers are 9.17.10.4459 and the Nvidia drivers are 376.48. The Intel drivers are updated ones from Microsoft because Intel basically gave everyone the middle finger; when asked to update the 3000 series drivers to Windows 10. Everything else is up to date, power settings are optimized for maximum performance, all power saving features have been disabled, all cores unparked, hdd is defragged etc etc. I have edited my console variables to include r.gpustatsenabled=0. Lastly, I made a shortcut, to the editor, that I can right-click and ensure that I run it with the Nvidia card.

What happens is I load up the game editor, open up a blueprint, select the mesh portion of it, then try to mouse-over things like the mesh or the material. As soon as I do, GPU usage shoots up to 100% and hangs(running MSI Afterburner to see GPU stats), then the program crashes with either a graphics removed or hung error. Over and over again… It’s not crashing from temperatures or anything like that. This bug is 100% repeatable; on my laptop. This was supposedly fixed in a recent QFE patch, but it didn’t fix it. How there has been a patch to 4.14.2 and it still isn’t fixed.

(Bug report section wasn’t letting me post and kept giving me errors)

CCan you attach your crash logs as well so the team can take a closer look?

When I put the -d3ddebug option on the shortcut, it gives me an error every time saying “dx11 feature level 10.0 is required to run the engine.” However, when it’s not there, the editor opens up just fine. This was the only log I could produce.

Still Experiencing Driver failures in 4.14.2

The issue on my end can be triggered from editing mesh and material slots to moving the mouse over various actors and objects details to opening and closing Blueprints, most things can trigger a black screen and then crash to desktop with a Driver recover bubble popping up.

-D3DDebug in use for ue4error.log.txt attachment

Things i have tried,

New drivers, checked Card temps , memory checks, clean projects in 4.14.2, etc

My card is on the low end Nvidia Geforce 610 GT but it worked well enough for me in 4.13 and prevoius engine builds with little to no issues other then low FPS when i had a ton of higher end render effects or lots of geometry going on.

I love the features of 4.14 and really want to make use of this and future versions but things are to much like a mine field at the moment to use this engine thanks for working on this issue and this engine.

answer hub post

updated post 1/12/17 with a zip containing new log file with error, call stack and machine id form error window along with a mini dmp file in case that helps.(recenterror.zip)

This is almost certainly graphics card driver related bud. I have been having this issue with UE4 for months now on and off, from around version 4.11 to 4.14, I tried almost literally everything and the only solution I found was to downgrade my video card drivers.
I also gave my system a clean as it was pretty dusty.

I’m using an AMD card though so the drivers I am using are 15.12. Since installing them I have had zero issues in over a month now, whereas it was crashing 4 or 5 times a day before that with the latest 16.12 drivers, and every other driver version since 15.12.
So check around to see which older Nvidia drivers are confirmed stable and get them installed.

Good luck!

4.14.3
This is still a thing, crash crash and more crash.

Crashes repeatedly for me. I’m losing my marbles. 4.13 worked fine, 4.14 makes an nvidia quadro 1000m with 2gb ram die. I will post specs or crash reports if they’re pertinent but I am super bummed out right now.

Adding my experience to the pool of unlucky users.

Crashes as well on a R9 380. Drivers have been updated.
4.10 engine was not crashing
4.14 crashes randomly
No other games crashes.

And it looks like Epic already fixed it. Unreal Engine Issues and Bug Tracker (UE-37999)
Though, won’t be released until 4.15, not hotfix for 4.14 ?? :eek: :eek: :eek:

We have fixed one cause of the crash, but other causes still exist and are under investigation. The fix actually went into the 4.14.2 Hotfix, and our data is showing that we have reduced the frequency of the crashes (or rather the number of users who are experiencing them) by possibly up to about 40%. We will continue to work to identify the cause of the remaining crashes. Sharing your system specs and 100% repro steps (including assets that cause the crash) can help immensely. (please post your information to the UE4 Answerhub Bug Report section.)

Thanks

Hey Stephen,

I’ve posted my report here : Graphic driver Crash - AMD R9 380 - UE4 AnswerHub

It wasn’t easy to get though, most of the time the Editor would crash without generating a report.

Thanks

I think I might have found a workaround solution for now!!! In the content browser pane: click the little eye that says “View Options” and uncheck "Real-Time Thumbnails."

I spent several minutes rapidly rolling my mouse over mesh/materials preview windows, while in a blueprint, and it hasn’t crashed yet! Normally, it would have crashed in <5 seconds of doing that. Nothing has changed, in terms of my laptop. Before unchecking that option, even while in 4.14.3, it would still crash every time.

Wow! After uncheck "Real-Time Thunbnails, editor is working well.
Thanks IronicParadox.

Nice find IronicParadox turning off Real-Time Thumbnails has reduced the crashes i was having in 4.14.3 by a significant amount, i still get a crash when opening an instanced material shortly after compiling a parent but if i wait for the compile to complete it dose not crash.

Before finding the above workaround i had been testing the launch option -opengl4 which in my case stabilized 4.14.3 for what i use it for i did notice some material setups i had made did not function in this rendering mode.

Glad it helps! Yeah, I had been stuck using opengl as well and it’s compatibility/performance isn’t all that great. I spent a great deal of time trying to rule things out and it all honed in on the real-time thumbnails. I can’t even tell you how many hours I spent trying to figure it all out.

The only other thing that I’ve noticed is that it does cause a little bit of hard drive thrash on each thumbnail highlight. I’m probably going out on a limb here, because I don’t really know the inner workings of the editor or the graphics drivers, but maybe the graphics card expects information to be loaded and if the hard drive doesn’t load it in a specific amount of time, then it causes the graphics card to hang or be removed(my error is almost always gfx removed). Another possibility is that it’s getting stuck in some infinite loop; which sounds the most likely to me. I’m sure a dev could debunk these theories though.

I can definitely say that as the program gets ready to crash, gpu usage shoots up to 100%. You can even draw back the settings to the point that the card doesn’t even use 30% of the gpu, while playing in viewport, and it will still shoot up to 100% usage when the thumbnail crash happens. I will have to play around with it all some more and see because it doesn’t seem to be tied to the TDR settings either. I can set TDR to something higher and all it will do is make my computer sit there for that duration before it crashes the rest of the way out. You can try underclocking into oblivion and it doesn’t change anything either. Example: I can underclock to 1/5th of the gpu’s normal stats and it will crash every time.

I’m on 4.14.3 binary version. Currently, as soon as I open my master** animation blueprint** this crash occurs. My animation blueprint is quite complex and uses many nodes and I had ~6 tabs open. This crash didn’t occur in 4.12.5.

Is the new layout of the animation editor more rendering intensive?

[SPOILER]
Fatal error: [File:D:\Build++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:176]
UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225]
UE4Editor_D3D11RHI!FD3D11Viewport::PresentChecked() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:275]
UE4Editor_D3D11RHI!FD3D11Viewport::Present() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:458]
UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:562]
UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1347]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindow_RenderThread() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:486]
UE4Editor_SlateRHIRenderer!TGraphTask<FSlateRHIRenderer::DrawWindows_Private'::35’::EURCMacro_SlateDrawWindowsCommand>::ExecuteTask() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\async askgraphinterfaces.h:868]
UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async askgraph.cpp:932]
UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async askgraph.cpp:679]
UE4Editor_RenderCore!RenderingThreadMain() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:320]
UE4Editor_RenderCore!FRenderingThread::Run() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:454]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]
[/SPOILER]

Thank you IronicParadox, 4.14.3 was unusable until i turned off “real-time thumbnails”. Whether it still crashes from other issues . . . i hope not. But again thank you, had been very frustrating.

I switched to Forward Rendering and have since then no more crashes. I think the GBuffer got too big to handle for my graphic card when using the animation blueprint.

Hi all.

I’m glad that some of you are finding workarounds for this issue.

I want to update all of you that we are still looking into these crashes, and we have logged a new ticket for tracking them: Unreal Engine Issues and Bug Tracker (UE-42280)

Cheers