Tiling textures in landscape material

Hi all!
I’ve been using UE4 for a while now, but there’s one thing I still can’t figure out. There is always a lot of visible tiling of my textures. I’ve tried to blend multiple textures, but still a lot of tiling. See the attached screenshot.

Is it just because I have terrible textures? Or did I miss something when setting up the landscape material? Or do I need to blend more textures to get a more realistic look?