TickComponent is not executed in ue 4.13

Hello guys,

I was using TickComponent in ue 4.10 an it worked. I upgraded at 4.13 and now TickComponent is no more executed.
This is the method:

void UEditingComponent::TickComponent(float DeltaTime, enum ELevelTick TickType, FActorComponentTickFunction *ThisTickFunction)
	Super::TickComponent(DeltaTime, TickType, ThisTickFunction);
	GEngine->AddOnScreenDebugMessage(-1, 5.f, FColor::Yellow, TEXT("this text is never printed"));

This is where i create the component:

UpEditLunghezza = NewObject<UEditingCone>(this);
	if (UpEditLunghezza)
		UpEditLunghezza->AttachToComponent(RootComponent, FAttachmentTransformRules::KeepRelativeTransform);
		UpEditLunghezza->Constructor(1, Raggio * 2.3f, ConeMesh, EditableNormalMaterial, EditableSelectedMaterial, GrowCurve, this);

Constructor in a method where I inizialize the component, inside this method I tried everything to tick the component:

	PrimaryComponentTick.bCanEverTick = true;
	PrimaryComponentTick.bStartWithTickEnabled = true;
	bTickInEditor = true;
	bAutoActivate = true;
	bAutoRegister = true;
	PrimaryComponentTick.TickGroup = TG_PrePhysics; 

in the 4.10 version with only bCanEverTick and bStartWithTickEnabled it worked.
The actor tick work properly.

Any ideas?

I’ve noticed in 4.14.2 if I add TickComponent to a c++ component while that component was already part of a blueprint, I need to delete it from the blueprint then compile/save and re add it or it will never tick.

thanks for the answer but I have already figured out the problem some times ago, now I mark solved

I just moved “PrimaryComponentTick.bCanEverTick = true” from the constructor to beginplay and now it works

Thanks! Works for me (UE 4.16)