Third person tutorial doesn't work

I opened a fresh third person blueprint to find a small green help thingy. Following it’s path, I found the tutorial for building a blueprint third person character.

I followed that tutorial and discovered the same problem as I often do. The tutorial doesn’t match what happens in the engine.

I’m using 4.6 and performed the tutorial twice, hitting the same problem. Instead of behaving like the factory-built third-person blueprint where you can run in any direction and control the camera freely, using WASD causes the character to run along those specific global axes, and the camera is only movable by mouse when moving and doesn’t go up or down.

- YouTube This is the tutorial, and the video when I discovered this problem. Everything seemed to be running fine up until this point.

Movement seems to be based on the character’s local location. The direction that WASD turns the character changes as it is rotated, so it seems like it’s based on local location.
No idea what’s causing this. Does anybody else?

I’ve followed the tutorial a couple of times to the point where the character is functioning just as expected or as you describe as the “factory-built third-person blueprint.” Did you start with a blank project with starter assets? (Not a blank third person project where this may cause a control conflict.)

“Using WASD causes the character to run along those specific global axes” -If I understand you correctly this is expected behavior where the character turns to face the direction he is moving. Are you finding this not the case?

“The camera is only movable by mouse when moving and doesn’t go up or down” -This is not expected behavior but I was not able to reproduce this issue. If you can you provide your project in a zip file I will compare to see where there may be a mis-step in the tutorial.

Here’s my project. I don’t have an easy way to provide a video, so I hope this works.

I did start with a blank project with starter content. I had the pre-built 3rd person blueprint open beside it and compared the blueprints. I can’t see the difference between the mouse and keyboard controls. I did not include the touch controls. Are those really important?

Thanks very much for offering to help. Merry christmas.

Enable “Use Pawn Control Rotation” in your camera boom → this should solve all your problems :slight_smile:

Thank you! That did the trick. :smiley:

At one point, the guy in the tutorial said “go to your spring arm and turn this thing off.” I searched for this thing, but found this different thing instead. I assumed it was the same or similar thing, just renamed as the engine updates.

It’d be super nice if Epic Games would go through their tutorial videos and add annotations to the video stating how things have changed for that step. I’ve seen it done on a few videos and it is really super helpful. Or maybe a link to a page using a list of changes with video timestamps. That may be easier. I know I and my friends would really appreciate it while trying to learn the engine.

Again, thanks super much. <3

Thank you fighter5347 for your answer. I reviewed the video here:

https://www.youtube.com/watch?v=_Y8ZOLGZQRM&index=12&list=PLZlv_N0_O1gZS5HylO_368myr-Kg2ZLwb

Between the 4 and 6 minute mark, Zak explains that he changes the “spring arm” name to “camera boom” and turns on “Use Controller View Rotation.” He then adds a camera to the camera boom (parent) and turns off “Use Controller View Rotation” for the CAMERA only -because the “camera boom” is already using “Use Controller View Rotation.” Otherwise both the camera and camera boom would be using “User Controller View Rotation” and thus would not function properly.