Download

Think it's a problem with the Event Play and Event Ticks

Ok, so I have no idea what’s going on. I’m not getting any errors when I hit play yet nothing moves. I have seven planets that rotate around a sun, and a flying pawn I made myself. When I hit play, the planets aren’t moving and my pawn only moves back and forth??? It doesn’t roll or pitch or yaw, it just moves back and forth while the rest of the level seems to be frozen. It happens in every single map and I haven’t changed anything since last night, when it was working perfectly fine, except created some materials.

Please help, I know its kind of vague but I’m new to this and this error just doesn’t make any sense to me. I have no clue where it could be based. I’ve tried restating Unreal and my computer, but it’s still the same.


the level


these are the planet’s blueprints for the rotation


how the pitch works (its the same for yaw and roll)


and literally the only thing that still works, moving forward and backwards

so, things that work: camera toggling, pause menu, moving back and forth
things that spontaneously no longer work: planet rotation, all other pawn movements