the texture fail on packaged version

Hi,

I’m having a problem with a project that I’m uploading from 4.10 to 4.13.

here I have some mesh that can switch the material by BP, in this case just the floor and the dome. When I test on the editor it looks well. Before at 4.10 it looks well in the editor and after package.

but now when I package the project this is how it looks:

I have re-imported the texture and rebuild the material but keep the same problem. it also happens with some material from the “starter content” folder.

I have check all the bp for problems compiling in the new version, but there is no problems to compile.

so I guess there is something new that limit the textures (4k the dome, 2K the floor) used on the bp, but I can’t find what it’s.

for the help

Hi geverk,

Could you clarify a few things for me? It looks like in the second image the blue glow spots are a lot darker on the dome. Is that the issue you are pointing out?

Also you mentioned this issue occurs with some starter content, could you point out what specific assets have this issue.

If I understand you correctly, you are saying that some textures don’t display properly on a packaged build and they are typically 4k. In what ways (other than the darker texture in the image above) are the textures failing?

,

Ed

oh another interesting detail, when I open the editor and play the materials also have this problem with the textures but if I open one texture in the content browser, no matter witch one, the problem is solved just for the editor. remains on the packaged version.

yes the texture looks blurry, (the dome is the most evident) so in that images the blue lines disappear (4k texture) with starter content (2k textures) in this project there are two in use with this switch option by BP, having both the same problem (M_Wood_Walnut and M_Wood_Pine)

I ran a test and was unable to reproduce your issue. My test involved creating a blueprint that switched between two materials (the walnut and pine materials you mentioned earlier). Then packaging the game and while playing pressing the 1 and 2 key to swap materials.

However, the texture only looked blurry for a less than a second then updated to full res once fully loaded.

Could you try to make a simple test like I have done that reproduces the issue. That should help narrow down things. After you have made a simple test that reproduces the issue please update me here with the steps you took so that I can reproduce this on my end.

Thank you,

First to check it.

I have been doing many test, and finally i find is a problem with a BP from the market place, the Hal Archviz Toolkit, the thumbnail render BP. I’m not sure what happens but the problem only happens when that BP is on the scene.

I will contact them.

Sorry for your time, and again!

Confirmed the issue was with marketplace content. This post will be marked as resolved for tracking purposes. To reopen simply comment.

,

Ed