Download

Texture sharpness is different in PIE VR versus packaged game VR

Dear All,

I have a VR experience which contains some high resolution textures (paintings). The problem I am experiencing is that the textures appear sharp during play-in-editor while they appear somehow blurry in the packaged game. I tried to play with the mipmap settings (NoMipMaps) for the textures. That made them a bit better in the packaged game, but still they don’t look as sharp as when played in the editor when seen from the same distance.

One thing I noted is that, while playing in game, I get close enough to the textures, then they look sharp. This indicates that it could be a LOD related behavior. Is it likely that when playing in the editor the engine applies a different way to chose the LOD versus when playing the packaged game? If this is the case, anyone knows how to ensure the same behavior in the packaged game as in the editor preview?

Thanks in advance!

Cheers,
M.

I do know that the defaults for screen percentage seem to be different between packaged games and PIE. Maybe take a look if it differs between both.

After some investigations I found where the problem was and also a solution to it. I will describe it below for future memory.

The packaged game is applying by default different Scalability Settings than the editor (PIE). The editor was set to Epic for everything, while the packaged game sets itself (auto) to a lower level. By executing the following console command in the Level Blueprint I was able to force the Texture quality to Epic in the packaged game.

sg.TextureQuality 3

Capture.PNG

Reference: https://docs.unrealengine.com/latest…nce/index.html

I am now experimenting with the other Scalability Settings to see what difference they make on the visual quality of a VR experience.

Cheers,
Marco.