Download

Suddenly unable to compile the engine, UBT error

Ever since I started my pc today I’ve been unable to compile the engine, UBT just prints a nondescriptive error and quits.

It worked just fine a few days ago… now it doesn’t. I don’t think I changed anything.
The same error pops up regardless of which version I try to compile, reinstalling VS 2017 did nothing.
Game projects using a launcher engine still compile fine though. It’s extremely strange that it would just randomly stop working…

Maybe I’ve missed something important when reinstalling VS? (There doesn’t seem to be a way to change the installer to english)
c8e534ea0e7aa90bcc20993ec48675d8e47e7195.png 2997558b24b0187c4bbf2bdf7c7808c02079b26a.png 84dbe169697bd25b27e85061f716cc53d8616b0b.png

Just the defaults for .net desktop development, c++ desktop development and c++ game development. And the windows sdk 8.1 because UBT wanted to have it.

In case anyone else ever stumbles over this bug, the solution is to disable “Faster Project Load” in Options > Text Editor > C/C++ > Experimental, which was on by default for some reason.
Having Visual Assist and this setting enabled at the same time causes the error.