Download

Subdivided Skeletal Mesh shadow has visible divisions

Solved! : Ah I figured it out. “Set Light Attachments As Group” on the main parent mesh.

I’ve been working on creating characters out of multiple meshes.

The shadows always look bad on a skeletal mesh that has attached children.
There’s a visible division for some reason.

Right now I set it up so there’s a main mesh and it has all the animations or ragdoll physics running on it. I then attach child skeletal meshes and set their master pose component to the parent mesh so it all matches up. However the shadows don’t work well. Maybe I’m missing some setting for shadows?

I also tried Use Attached Parent Bounds on all attached children and it didn’t help.
Setting to Two Sided shadows on all meshes doesn’t help either since the division is visible right on the sillhoette. I can also tell that the shadow quality for the main mesh is much higher than attached meshes. It’s like it’s rendering on a separate shadow map or some different settings. Ideally I’d want the entire mesh and its children to render into the shadow map as 1 object.