Streaming in a sub level with AI (bots) in it no responding

I ran in to a problem the other night and did some googling but found only dead ends.
here is my problem:
I have a Main level or Persistent level. lets call this level “Global”. the player character is in this level
I have two Sub levels “Sub_Level_A” and “Sub_Level_B”
I start off with “Sub_Level_A” loaded, this contains no Bots.
after a point I Stream in “Sub_Level_B” which contains Bots or pawns with AI.

the problem is they dont respond or move. the AI is very simple they just move toward the player. the odd part is if I load “Sub_Level_B” only or as the Persistent level the AI works fine.
is there something im missing when streaming in a level with AI or do I need to spawn them in the Persistent level?

any help would be amazing! its really got me at a halt .

Thanks in advance :slight_smile:

Under project settings>navigation mesh , have you tried setting the runtime generation to dynamic?

@drb1992 Thanks for reply! I will try once i get home!!! thanks!

you are a god amongst men… it worked . thank you!